Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#3180 closed defect (fixed)

GetBooks needs to report when it cannot contact a server

Reported by: greenfeld Owned by: humitos
Priority: Unspecified by Maintainer Milestone:
Component: GetBooks Version: 0.94.x
Severity: Unspecified Keywords: easy-hack, patch
Cc: humitos Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

  1. Start GetBooks on an XO which is not connected to any network (it can be in ad-hoc or Mesh mode).
  2. Click on one of the "Catalog" choices in the sidebar.
  3. You will be told "Sorry, no books could be found" in the status bar, which is almost meaningless. We should at least say we could not connect to the server although I do not know what kind of "server" we should say it is to keep terms simple ("book server", "catalog server", etc.).

The ideal situation would be for Sugar itself to query a host and figure out if we are online, isolated, behind a redirect firewall, etc., but that is a more complex implementation case.

Seen in 11.3.0 os880/GetBooks-10.

Attachments (1)

0001-Report-when-could-not-reach-the-server-SL-3180.patch (2.1 KB) - added by humitos 9 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by godiard

  • Keywords easy-hack added

comment:2 Changed 9 years ago by godiard

  • Keywords 12.1.0 added

comment:3 Changed 9 years ago by godiard

  • Owner changed from godiard to humitos
  • Status changed from new to assigned

comment:4 Changed 9 years ago by humitos

  • Cc humitos added
  • Keywords patch added

comment:5 Changed 9 years ago by erikos

  • Keywords 12.1.0 removed

comment:6 Changed 9 years ago by godiard

  • Resolution set to fixed
  • Status changed from assigned to closed

I am not over enthusiastic with the patch, because is complex, and is more spaghetti in a already spaghetti activity, but solves the error.
In the future, we can improve it.

comment:7 Changed 8 years ago by dnarvaez

  • Milestone 0.94 deleted

Milestone 0.94 deleted

Note: See TracTickets for help on using tickets.