Opened 10 years ago

Closed 9 years ago

#3174 closed defect (notabug)

Turtleart Gdk-ERROR

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by tonyforster)

OS880 X0-1.75
reopening the attached ta file just produces the gdk error

Traceback (most recent call last):

File "/home/olpc/Activities/TurtleArt.activity/TurtleArt/talogo.py", line 433, in doevalstep

self.step.next()

File "/home/olpc/Activities/TurtleArt.activity/TurtleArt/talogo.py", line 413, in _evalsym

result = self.cfun.fcn(self, *self.arglist)

File "/home/olpc/Activities/TurtleArt.activity/plugins/turtle_blocks_extras/turtle_blocks_extras.py", line 305, in <lambda>

lambda self: primitive_dictionarysee?())

File "/home/olpc/Activities/TurtleArt.activity/plugins/turtle_blocks_extras/turtle_blocks_extras.py", line 1025, in _prim_see

self.tw.lc.update_label_value('see', color_index)

File "/home/olpc/Activities/TurtleArt.activity/TurtleArt/talogo.py", line 535, in update_label_value

for block in self.value_blocks_to_update[name]:

KeyError: 'see'
1318110288.001990 WARNING root: No gtk.AccelGroup in the top level window.
1318110288.083626 WARNING root: No gtk.AccelGroup in the top level window.

Gdk-ERROR : The program 'sugar-activity' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.

(Details: serial 173212 error_code 11 request_code 53 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;

that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

aborting...
Terminated by signal 6, pid 1768 data (None, <open file '<fdopen>', mode 'w' at 0xd96078>, '5f81fff55e8922f67100f382e682d56c38ac0303')

Attachments (1)

Turtle Art Activity.ta (700 bytes) - added by tonyforster 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by tonyforster

comment:1 Changed 10 years ago by tonyforster

  • Component changed from untriaged to Turtleart
  • Description modified (diff)
  • Owner set to walter

comment:2 Changed 10 years ago by tonyforster

This bug is not reproducable after a reboot. Probably just another example of the video driver problems on the 1.75 being tracked at laptop.org

comment:3 Changed 9 years ago by walter

  • Resolution set to notabug
  • Status changed from new to closed

Please reopen if this turns out to be a TA problem.

Note: See TracTickets for help on using tickets.