Opened 10 years ago

Closed 10 years ago

#3162 closed defect (fixed)

Turtle Art collaboration breaks when a turtle is manually dragged

Reported by: garycmartin Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

While trying to reproduce some bugs from last week in Turtle Art 114, version 116 seems to have now lost almost all ability to share turtles. When collaborating between 11.3.0 build 8 XO-1.75 and an XO-1, I'm seeing the two Turtles of each collaborator appear, but I get perhaps at best only one event transmitted, then nothing more. Running simple code, dragging a turtle position, nothing updates on the other client. Logs have no interesting messages/errors.

Change History (8)

comment:1 Changed 10 years ago by garycmartin

  • Summary changed from Turtle Art 116 to Turtle Art 116 Collaboration seems broken

comment:2 Changed 10 years ago by garycmartin

After leaving the two machines for 5min, the two TA clients appear to have started to synchronise... Hmmm.

comment:3 Changed 10 years ago by garycmartin

Problem appears to be triggered if you try and drag either of the turtles on screen, comms between the two clients seems to stop for a number of minutes and then catches up again.

comment:4 follow-up: Changed 10 years ago by walter

Is that problem new to v116 or did it happen in v114 as well? I'll investigate in any case, but it would be good to know if it was due to some change I made.

Thanks for testing.

comment:5 in reply to: ↑ 4 Changed 10 years ago by garycmartin

  • Summary changed from Turtle Art 116 Collaboration seems broken to Turtle Art collaboration breaks when a turtle is manually dragged

Replying to walter:

Is that problem new to v116 or did it happen in v114 as well? I'll investigate in any case, but it would be good to know if it was due to some change I made.

Just retested in v116 and v114. Re-confirmed that dragging any turtle in either version stalls out collaboration. Sometimes the drawing event history catches up after perhaps 1min or so, other times you start getting new events only, and sometimes the clients never reconnect (I'm only testing with two TA clients at the moment). If you avoid dragging a turtle, collaboration seems reasonably robust between two clients.

comment:6 Changed 10 years ago by walter

With this patch, I don't share the turtle position/orientation until the button is released.

http://git.sugarlabs.org/turtleart/mainline/commit/5ddf2801aac28eb244126bfc3bf36686ca76ca06

Thus, rather than flooding the network with each change in position, it is only necessary to send one update. Seems to have fixed the problem.

comment:7 Changed 10 years ago by walter

Fixed in v117

comment:8 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.