Opened 8 years ago

Closed 4 years ago

#3147 closed defect (fixed)

Hovering Home list view un-favorited star provides confusing feedback

Reported by: FGrose Owned by: manuq
Priority: Normal Milestone: Unspecified
Component: Sugar Version: 0.97.x
Severity: Minor Keywords: design accessibility
Cc: garycmartin, humitos Distribution/OS: OLPC
Bug Status: New

Description

Observed on os8 on an XO-1.75

When one hovers an un-favorited item star in the Home list view, the star takes on the favorite colors, so there is no feedback if it is clicked.

Previously, the star would fill with gray on hover, and become colored if clicked. This was better.

Change History (11)

comment:1 follow-up: Changed 8 years ago by erikos

  • Cc garycmartin added
  • Owner set to erikos
  • Status changed from new to assigned

Hmm, maybe if the item is favored (star is colored) it should just do the inverse when hovering over it and uncolor the star?

comment:2 in reply to: ↑ 1 Changed 8 years ago by FGrose

Replying to erikos:

Hmm, maybe if the item is favored (star is colored) it should just do the inverse when hovering over it and uncolor the star?

The gray shading is less than ideal because the image contrast difference varies with the chosen colors and may be insufficient (an accessibility problem, especially for small items and less-than-ideal visual conditions). I would prefer appropriately sized, gray, rounded borders, like those used to highlight the activity icons in the regular Home view. This would work on the stars for both the favorited and un-favorited activities.

comment:3 Changed 7 years ago by FGrose

  • Bug Status changed from Unconfirmed to New
  • Keywords design accessibility added
  • Milestone changed from 0.94 to Unspecified by Release Team
  • Version changed from Unspecified to Git as of bugdate

From ticket #3090 - http://git.sugarlabs.org/sugar/mainline/commit/cc64af8187b26a5aafa0c43d84c794ab071d8312?diffmode=inline :

... hovering over the icon should reflect the visual change that will occur
once you click on the icon: the icon will be colored in the owners color
when the item is favored, therefore we need to color it in the owners
color as well when we hover over the icon.

The objective should be reworded to the following:

... hovering over the icon should visually reflect that a change that will occur
once you click the icon: ..., therefore we need to highlight the icon in a
visually clear manner when we hover the icon.

As noted above, graying has accessibility issues. A gray, rounded box outline would work well for both colored and uncolored (favorited and un-favorited activity) icons.

comment:4 follow-up: Changed 7 years ago by garycmartin

We could stitch over to the grey rounded rectangle mouse over, press, visual feedback we use on the Home view for Activities (currently broken after the GTK3 sugar shell port, you'll need to look on an 12.1 build). The star icon would only change colour when it was pressed, providing the needed feedback.

comment:5 Changed 7 years ago by humitos

  • Cc humitos added

comment:6 Changed 7 years ago by manuq

  • Owner changed from erikos to manuq

comment:7 Changed 7 years ago by erikos

  • Distribution/OS changed from Unspecified to OLPC
  • Milestone changed from Unspecified by Release Team to 0.98
  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Minor
  • Version changed from Git as of bugdate to 0.97.x

see #3989 for the press feedback for the star icon.

comment:8 Changed 6 years ago by dnarvaez

  • Milestone changed from 0.98 to Unspecified

comment:9 Changed 6 years ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:10 in reply to: ↑ 4 Changed 6 years ago by FGrose

  • Bug Status changed from Unconfirmed to New

See comment 4 by garycmartin:

... The star icon would only change colour when it was pressed, providing the needed feedback.

The star icon continues to change color when hovered rather than only when pressed. This is confusing especially when an Activity is unfavorited. (The clicked and hovered icon still is colored, as if the action had not been effected.)

comment:11 Changed 4 years ago by Gonzalo Odiard

  • Resolution set to fixed
  • Status changed from assigned to closed

Don't change star color on hovering - Fixes #3147

Change the star color on hovering cnfuses to the user,
because think the favorite state has changed.
This can be seen in the activities list view, in the Journal listview,
and in the Journal detail view.

Changeset: 99eb5447f078d04177cba99f9d0334602ef897d6

Note: See TracTickets for help on using tickets.