Opened 8 years ago

Closed 8 years ago

#3136 closed defect (duplicate)

Restore should extract into Journal

Reported by: reuben Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Restore Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Restore currently copies the the backup into the Journal and then restores from that file. The backup file itself can be large and on resource constrained devices, XO-1, can fill the Journal prior to restore. Restore should directly extract from the USB drive rather then first copying the backup file into the Journal.

Change History (1)

comment:1 Changed 8 years ago by sascha_silbe

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #496. This is a shortcoming in Sugar (which does the copying before Restore is even started). However icarito and I are working on providing a workaround by implementing a custom Object Chooser that directly access the storage device. Backup already does this for writing the backup bundle, so we only need to generalise this a bit and wire it up in Restore. See also #2373.

Note: See TracTickets for help on using tickets.