Opened 8 years ago

Closed 6 years ago

#3130 closed defect (notsugar)

NetworkManager in dx3g040 on XO-1 gets seg-flt on startup

Reported by: hal.murray Owned by: m_anish
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Dextrose Version: Unspecified
Severity: Unspecified Keywords: dx3
Cc: sascha_silbe, dsd, m_anish Distribution/OS: Dextrose
Bug Status: New

Description

It worked well enough after the install so that I could enter a WiFi password and ssh in. After a reboot, NetworkManager dies during initialization.

I tried Discard-Network-History, but that didn't help.

Stack trace from /var/log/messages attached.

Attachments (1)

stack (9.7 KB) - added by hal.murray 8 years ago.

Download all attachments as: .zip

Change History (13)

Changed 8 years ago by hal.murray

comment:1 Changed 8 years ago by erikos

  • Keywords silbe added

Please check with the dextrose people as well. cc'ed Sascha.

comment:2 Changed 8 years ago by erikos

  • Keywords dsd added

Adding Daniel as well, as he is our NM hero.

comment:3 Changed 8 years ago by erikos

Just tested with os7: connected to my AP and then rebooted two times and did not see the NM crash here.

comment:4 Changed 8 years ago by sascha_silbe

  • Cc sascha_silbe dsd m_anish added
  • Component changed from untriaged to Dextrose
  • Keywords silbe dsd removed
  • Owner set to bernie

We've seen this in test builds before, but only with an "old" version of NetworkManager (from the frozen OLPC repos). dx3g040.packages.txt shows NetworkManager as version 0.8.4-2.git20110622, which is exactly what we cherry-picked from Fedora.

comment:5 Changed 8 years ago by sascha_silbe

  • Owner changed from bernie to m_anish
  • Status changed from new to assigned

comment:6 Changed 8 years ago by hal.murray

  • Summary changed from NeteworkManager in dx3g040 on XO-1 gets seg-flt on startup to NetworkManager in dx3g040 on XO-1 gets seg-flt on startup

yum info on os7 from olcp says:

Name : NetworkManager
Arch : i686
Epoch : 1
Version : 0.8.5.92
Release : 1.git20110927.fc14

I haven't seen any troubles with it.

comment:7 Changed 7 years ago by m_anish

  • Resolution set to fixed
  • Status changed from assigned to closed

This has been tested to be working from dx3g055 onwards. Please re-open if you see this again.

http://download.sugarlabs.org/dextrose/testing/dx3/xo1/dx3g055.img
http://download.sugarlabs.org/dextrose/testing/dx3/xo1/dx3g055.crc

comment:8 Changed 7 years ago by hal.murray

  • Resolution fixed deleted
  • Status changed from closed to reopened

I tried dx3g091. Same symptoms.

This time, I don't have a /var/log/messages so I can't get a stack trace.

I don't see syslogd or rsyslogd running.

I booted again and didn't see any blinks on the network LED. (I might have missed something.)

My Settings / Network says "ord.freedesktop.NetworkManager service not available"

The Nieghborhood view shows only my icon in the center.

comment:9 Changed 7 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to New

On an XO-1 running dx3g091, I haven't (yet) encountered NetworkManager crashing on boot, but it did crash randomly after resume.
Hal, do you have "Automatic power management" turned on in the Power Control Panel section? If so, please try turning it off. While NetworkManager shouldn't crash (that's definitely a bug), aggressive suspend / resume is known to be problematic on XO-1.

comment:10 Changed 7 years ago by hal.murray

Hal, do you have "Automatic power management" turned on in the Power Control Panel section?

I can't be really sure without reinstalling to double check, but it's on my checklist so I'm pretty sure I would have turned it off.

Besides, it crashes before it finishes initialization so things are still busy enough to keep it from suspending. Check the stack trace above. NetworkManager crashes when powerd is starting.

comment:11 Changed 7 years ago by sascha_silbe

Thanks, Hal. That doesn't look good.

To give some background: we updated NetworkManager using an rpm cherry-picked from Fedora because the version from the OLPC frozen repositories was crashing at boot time (like it currently does for you, Hal). dx3g091 contains NetworkManager-0.8.5.93-1.fc14.

There are two possible approaches:

  1. Revert to the NetworkManager version used by OLPC (0.8.5.92-1.git20110927.fc14) and deactivate mesh support in Sugar.
  2. Roll a custom kernel to disable mesh at the kernel level (#3276). Possibly also revert to the previous NetworkManager version.

Given that the OLPC builds seem to work well enough even with mesh support, I'm leaning towards the first option. It also avoids forking the OLPC kernel rpm.

Anish, what do you think?

comment:12 Changed 6 years ago by dnarvaez

  • Resolution set to notsugar
  • Status changed from reopened to closed

Dextrose is not tracked here anymore.

Note: See TracTickets for help on using tickets.