Opened 11 years ago

Closed 11 years ago

#3115 closed defect (fixed)

unexpected behaviour in load_block.py

Reported by: aaguirre Owned by: walter
Priority: Low Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Trivial Keywords: python example bug
Cc: lobli182@… Distribution/OS: Unspecified
Bug Status: New

Description

after 4 runs of the load_block.py the 5th block is not connected to the stack of blocks. I'm testing calling with forward as the parameter for the python block with load_block.py loaded.

Attachments (2)

load_block.ta (798 bytes) - added by aaguirre 11 years ago.
run and look at the 5th follow block, is disconected from the rest
block is not attached.png (57.1 KB) - added by walter 11 years ago.
confirmed :P

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by walter

Could you please attach your project file?

Changed 11 years ago by aaguirre

run and look at the 5th follow block, is disconected from the rest

Changed 11 years ago by walter

confirmed :P

comment:2 Changed 11 years ago by walter

The problem was that I wasn't accounting for the overlap between blocks as they stack. The accumulated error eventually made it so that the blocks were positioned too far apart to doc.

http://git.sugarlabs.org/turtleart/mainline/commit/1d8dada5ba9e8578d98aaf29d1f081599f185a10

Patch will be in v117.

comment:3 Changed 11 years ago by walter

Fixed in v117

comment:4 Changed 11 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.