Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#3114 closed defect

Memorize: Crash trying to collaborate with custom game

Reported by: godiard Owned by: godiard
Priority: Unspecified by Maintainer Milestone:
Component: Memorize Version: Git as of bugdate
Severity: Major Keywords: 12.1.0
Cc: humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

If a user share a custom game, when other players try to share it, the sharer crash.

The log show:

1316502592.947223 DEBUG memorize-activity: buddy joined: rita
1316502592.947351 DEBUG memorize-activity: Buddy 'rita' was added to game
1316502592.947518 DEBUG sugar.presence.buddy: <Buddy object at 0x987bbe4 (PresenceBuddy at 0x991feb0)>: Blocking on GetProperties() because someone wants property color
1316502592.947772 DEBUG sugar.presence.buddy: __got_properties_cb dbus.Dictionary({dbus.UTF8String('color'): dbus.UTF8String('#FF8F00,#00A0FF', variant_level=1), dbus.UTF8String('ip4-address'): dbus.UTF8String('192.168.11.2', variant_level=1), dbus.UTF8String('key'): dbus.ByteArray('AAAAB3NzaC1kc3MAAACBAMG4Jg1WMU+R/oksuGs1+h9rGv+1Khs/b+c31PHMXjD8xc9bxF2emnq2VgzGuPgENROLiwn/OQu9I3xboAqNiFwcNrF8pvz6O1jl5FIE6sON32p4veqHfcLGWFb3JvvU1lOumWjDwJbaIOUCfKIx/gZ4uJpOfESfWLDOAlO1jHxBAAAAFQC5+10xQlGoc/DU61V3RPSOTmvcyQAAAIEAlPEnlkoIuDEbM0Bqeat+dGQN7o+FezVp34ekaPm+tMvfhqQMv9XnHoCfF0z0aabwTNRfo6xUiol/43uiC/PTQMT0d/4HtXWAK1MrrDyqU5YJXLWgM2qssQcbEoZJ1qBjh77CGjh2ha8DIqfkeG8c+O4ktkMpm2Eljr27VX986hoAAACBAJ+7SebNX2sfB6MfkxRsUSK2BZHj7Ha7luF1TCPeWMTsXlImMqIx1zsdpv+byCaBij3jK1T9nYIQFn97d5w1CLE+55nXYEm+OCES0ThHqerfh7GPBsF3wv0y9Iu8zrIuaIuaL0P0pPQlc2KkatskDIsU+ynWUX8hWm9XOdxWXc9Y', variant_level=1)}, signature=dbus.Signature('sv'))
1316502592.954240 DEBUG root: <Buddy object at 0x987bbe4 (PresenceBuddy at 0x991feb0)>
process 10084: Array or variant type requires that type string be written, but end_dict_entry was written.
The overall signature expected here was 'asaa{ss}' and we are on byte 6 of that signature.
  D-Bus not built with -rdynamic so unable to print a backtrace
Best voice for LANG es_AR.utf8 seems to be es-la Spanish-latin-american
Terminated by signal 6, pid 10084 data (None, <open file '<fdopen>', mode 'w' at 0x9bbcf40>, '27634c64668fb52569a81da8122d20bbaf7fcfa7')

This is a regression included with the changes landing in version 37

Attachments (4)

0001-Set-the-name-in-the-game-with-the-activity-title.patch (1008 bytes) - added by godiard 9 years ago.
0002-Fix-call-to-load_remote.patch (954 bytes) - added by godiard 9 years ago.
org.laptop.Memorize-2.log (15.7 KB) - added by erikos 9 years ago.
full log of the crash on A after applying Gonzalo's patches
smoke.memorize (32.1 KB) - added by erikos 9 years ago.
game created

Download all attachments as: .zip

Change History (16)

Changed 9 years ago by godiard

comment:1 Changed 9 years ago by godiard

These two patches should solve the issue. Use git HEAD to test.

comment:2 Changed 9 years ago by erikos

Patches do not work for me. Tried to share a game with two pictures, dbus error.

comment:3 Changed 9 years ago by godiard

Can you try with a game created after you applied these patches (or modifying the game to assure is saved)?

comment:4 Changed 9 years ago by erikos

Steps to reproduce:

on A:

  • open Memorize
  • go to edit mode
  • clear the game
  • select a paired game
  • add two pictures
  • change the title
  • go to play
  • share the game

on B:

  • join

---> on A the memorize activity crashes when B joins

1316772977.395301 DEBUG sugar.presence.buddy: __got_properties_cb dbus.Dictionary({dbus.UTF8String('color'): dbus.UTF8String('#FF8F00,#00A0FF', variant_level=1), dbus.UTF8String('ip4-address'): dbus.UTF8String('192.168.11.4', variant_level=1), dbus.UTF8String('key'): dbus.ByteArray('AAAAB3NzaC1kc3MAAACBAMG4Jg1WMU+R/oksuGs1+h9rGv+1Khs/b+c31PHMXjD8xc9bxF2emnq2VgzGuPgENROLiwn/OQu9I3xboAqNiFwcNrF8pvz6O1jl5FIE6sON32p4veqHfcLGWFb3JvvU1lOumWjDwJbaIOUCfKIx/gZ4uJpOfESfWLDOAlO1jHxBAAAAFQC5+10xQlGoc/DU61V3RPSOTmvcyQAAAIEAlPEnlkoIuDEbM0Bqeat+dGQN7o+FezVp34ekaPm+tMvfhqQMv9XnHoCfF0z0aabwTNRfo6xUiol/43uiC/PTQMT0d/4HtXWAK1MrrDyqU5YJXLWgM2qssQcbEoZJ1qBjh77CGjh2ha8DIqfkeG8c+O4ktkMpm2Eljr27VX986hoAAACBAJ+7SebNX2sfB6MfkxRsUSK2BZHj7Ha7luF1TCPeWMTsXlImMqIx1zsdpv+byCaBij3jK1T9nYIQFn97d5w1CLE+55nXYEm+OCES0ThHqerfh7GPBsF3wv0y9Iu8zrIuaIuaL0P0pPQlc2KkatskDIsU+ynWUX8hWm9XOdxWXc9Y', variant_level=1)}, signature=dbus.Signature('sv'))
1316772977.402266 DEBUG root: <Buddy object at 0xaca1cd4 (PresenceBuddy at 0xaf40270)>
process 3592: Array or variant type requires that type string be written, but end_dict_entry was written.
The overall signature expected here was 'asaa{ss}' and we are on byte 6 of that signature.
  D-Bus not built with -rdynamic so unable to print a backtrace
Best voice for LANG es_AR.utf8 seems to be es-la Spanish-latin-american
Terminated by signal 6, pid 3592 data (None, <open file '<fdopen>', mode 'w' at 0xa140a18>, '5bbc34810548a965e84adb1aa6643c64a622b69f')

comment:5 Changed 9 years ago by erikos

  • Milestone changed from Unspecified by Release Team to 0.94
  • Owner changed from erikos to godiard
  • Status changed from new to assigned
  • Version changed from Unspecified to Git as of bugdate

Changed 9 years ago by erikos

full log of the crash on A after applying Gonzalo's patches

Changed 9 years ago by erikos

game created

comment:6 Changed 9 years ago by godiard

  • Resolution set to fixed
  • Status changed from assigned to closed

Solved in Memorize 39

comment:7 Changed 9 years ago by erikos

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:8 Changed 8 years ago by godiard

  • Keywords 12.1.0 added

comment:9 Changed 8 years ago by godiard

Tested again in os12, and works ok. can anybody confirm?

comment:10 Changed 8 years ago by humitos

  • Cc humitos added

I tested these steps (between a 1.75 and 1.5 with os12 - Memorize 41) and they worked for me:

  1. Download "smoke.memorize"
  2. Open it from the Journal
  3. Public the activity
  1. Go to the other XO
  2. Go to the neighbourhood view
  3. Click on the shared memorize activity

Play!

comment:11 Changed 8 years ago by godiard

  • Status changed from reopened to closed

Ok, closing. If anybody see it again, reopen.

comment:12 Changed 7 years ago by dnarvaez

  • Milestone 0.94 deleted

Milestone 0.94 deleted

Note: See TracTickets for help on using tickets.