Opened 11 years ago

Closed 6 years ago

#3085 closed defect (notabug)

Get Books may make journal entries with old timestamps

Reported by: greenfeld Owned by: humitos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: GetBooks Version: 0.93.x
Severity: Unspecified Keywords: 12.1.0, easy-hack
Cc: humitos, sascha Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

  1. Using Get Books-9, download "The Black Cat" by "Edgar Allan Poe" in PDF format.
  2. Go directly to the journal view using the Sugar shortcuts. Do not use the goto-journal button in Get Books.
  3. You will find the downloaded item at the bottom of the list of Journal entries with older entries worked on above it, and not at the top as the latest item just saved.

Seen in OLPC 11.3.0 os3.

Attachments (3)

Screenshot of _Journal_.png (78.3 KB) - added by humitos 11 years ago.
Screenshot of _Journal_.2.png (75.6 KB) - added by godiard 11 years ago.
This is a screenshot shows the book at the bottom in the journal, but with the right time.
Screenshot of _Journal__1.png (61.4 KB) - added by godiard 11 years ago.
This

Download all attachments as: .zip

Change History (14)

comment:1 Changed 11 years ago by godiard

  • Keywords easy-hack added

comment:2 Changed 11 years ago by godiard

  • Keywords 12.1.0 added; 11.3.0 removed

comment:3 Changed 11 years ago by godiard

  • Owner changed from godiard to humitos
  • Status changed from new to assigned

comment:4 Changed 11 years ago by humitos

I couldn't reproduce this bug on XO 1.5 os9 and GetBooks version 11.

comment:5 Changed 11 years ago by godiard

Sam, can be this error related with a old journal bug (i can't find it now) where the items in the journal are not displayed in the right order?

Can you reproduce this error now?

comment:6 follow-up: Changed 11 years ago by greenfeld

Reproduced in 12.1.0 os10:

  1. Start the activity; Feedbooks should be active.
  2. Select "action & adventure" from categories.
  3. Select "The Call of the Wild" (top choice) from the list.
  4. Download as a PDF, and look at the Journal. The item will be at the bottom of the list.

comment:7 Changed 11 years ago by humitos

  • Cc humitos added

I tested it again on XO 1.75 os11 and GetBooks 11 and I still can't reproduce this bug. Screenshot attached.

Changed 11 years ago by humitos

comment:8 in reply to: ↑ 6 Changed 11 years ago by godiard

Replying to greenfeld:

Reproduced in 12.1.0 os10:

  1. Start the activity; Feedbooks should be active.
  2. Select "action & adventure" from categories.
  3. Select "The Call of the Wild" (top choice) from the list.
  4. Download as a PDF, and look at the Journal. The item will be at the bottom of the list.

I reproduced it, but I think is a Journal problem, not in the activity.
Attached are two screenshots:

In the first, you can see the book at the bottom, but with the legend "Seconds ago", then the date is ok, but is not sorted.

In the second, can see the item reordered after creating the first screenshot.

Adding sascha, to see if this is a expected behaviour (the journal needs time to reorder) or we should do anything special in the activity to request the reorder or maybe set a diferent metadata.

Changed 11 years ago by godiard

This is a screenshot shows the book at the bottom in the journal, but with the right time.

Changed 11 years ago by godiard

This

comment:9 Changed 11 years ago by godiard

  • Cc sascha added

comment:10 Changed 11 years ago by godiard

Sascha: Can you comment on this issue?

comment:11 Changed 6 years ago by quozl

  • Resolution set to notabug
  • Status changed from assigned to closed

Does not occur now, on Ubuntu 16.04 or Fedora 18, closing.

Note: See TracTickets for help on using tickets.