Opened 10 years ago

Closed 9 years ago

#3083 closed defect (obsolete)

Calculate failed to close at Sugar naming dialog

Reported by: greenfeld Owned by: rwh
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Calculate Version: 0.93.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

I attempted to close calculate after starting it up. But no matter how many times I pressed "OK" at the Sugar naming dialog (since it was not renamed), I could not get it closed.

To the best of my knowledge no calculations were made so it was attempting to close with no history of work.

I could not reproduce the issue after I saw it the first time. The exception seen every time the "OK" button was pressed was:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/sugar/activity/namingalert.py", line 341, in __keep_cb
    self._activity.metadata['keep'] = 0
TypeError: 'NoneType' object does not support item assignment

Seen with 11.3.0 os3/Calculate-37 on an XO-1.

Change History (1)

comment:1 Changed 9 years ago by garycmartin

  • Resolution set to obsolete
  • Status changed from new to closed

I can't reproduce this one here, please reopen if you can reproduce the bug.

Note: See TracTickets for help on using tickets.