Opened 10 years ago

Closed 9 years ago

#3075 closed defect (fixed)

Log launches second instance

Reported by: walter Owned by: wadeb
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Log Version: 0.93.x
Severity: Unspecified Keywords: 12.1.0
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Log 25 seems to have a new feature that disables Journal entries. Thus it never appears colored, as having been activated on the Home View. (Arguably, this is a legit design decision -- misguided IMHO). However, if there is a currently active Log and you click on Log in the Home View, a new instance opens. This 'start new' by default behavior is different from the behavior of all other activities, which seems to be a bug. Haven't looked at the code yet, but I am presuming they are related: the activity launcher, not seeing that there is an active instance because of the lack of a Journal entry starts new.

(Tested on XO 1.75 build os41)

Change History (2)

comment:1 Changed 10 years ago by garycmartin

FWIW the same misguided design decision to remove Journal support was also taken for Jukebox, rather than fixing the actual issue of having such activities store useful Journal state (for Jukebox this should obviously be a playlist). Note that for both Log and Jukebox the title input field has also been stripped out from the toolbars.

comment:2 Changed 9 years ago by godiard

  • Keywords 12.1.0 added
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in Log 28

Note: See TracTickets for help on using tickets.