Opened 8 years ago

Closed 6 years ago

#3074 closed defect (fixed)

Language screen in Control Panel hangs on load after setting lang from cmd line

Reported by: sj Owned by:
Priority: Low Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Major Keywords:
Cc: cjl Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Sugar 11.2, build 852, on an XO-1.5

I wanted to change my lang setting so I went into the Control Panel, opened the Language panel, saw the list of available languages, but didn't find it.

I opened a Terminal in Sugar, and used sugar-control-panel to try setting the language manually. The language I wanted still wasn't known, but to test s-c-p I set the language with it, to Spanish/Argentina and French/France, tried a dozen other languages (French, Thai, Hebrew/Israel, Estonian - only things from the old full list of languages), then set it back to English/USA.

I tried sugar-control-panel -h languages to lists all available languages - it returned only "none".

I returned to the visual Control Panel to view the list again - and encountered the bug.

Clicking on "Language" caused the title to change to "Language" with the title tab shown as expected -- with the Cancel/OK buttons. But nothing else renderd - I could still see the visual menu of the Sugar Control Panel -- and could click on other icons to load their panels.

I restarted Sugar to see if this would fix the observed bug. Instead, it led to all activities all disappearing from the desktop(!!). So there could be something more significant going on.

I can still open my visual Control Panel and Journal -- and the Language panel bug is still there [the others all work normally]. I'll try to reproduce on a clean install.

Attachments (1)

logs.SHC049002C6.2011-09-01.19-48-26.tar.bz2 (226.0 KB) - added by sj 8 years ago.
olpc-log output [from the command line, Terminal not being available]

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by sj

olpc-log output [from the command line, Terminal not being available]

comment:1 Changed 8 years ago by sascha_silbe

  • Component changed from untriaged to sugar
  • Severity changed from Critical to Major

Try removing ~/.i18n to unbreak Sugar (show the activities again).

If your language wasn't listed in the Control Panel section, trying to set it from the command line is bound to break things. We should prevent that (i.e. not change to setting if the language isn't supported), but I'd rather get rid of the CP code (it has other warts, too) than fix it.

What version of Sugar is this, BTW? 11.2 isn't a valid Sugar version.

comment:2 Changed 8 years ago by cjl

  • Cc cjl added

comment:3 Changed 8 years ago by cjl

Build os852 of release 10.1.2 contains Sugar 0.84, please test with a current OLPC image like release 11.2.0 (build 874) that contains Sugar 0.92.

comment:4 Changed 6 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from new to closed

If using a non existent language it just prints "I do not speak.." these days.

Note: See TracTickets for help on using tickets.