Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3072 closed defect (fixed)

Distance-25 activity cannot play wav file

Reported by: greenfeld Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Distance Version: 0.93.x
Severity: Major Keywords: 11.3.0
Cc: godiard Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

After both users press the "Start" button in Distance version 25, the originator stops working stating it cannot find a wav file it wants to play.

It looks like is trying to access a non-existant python object in the process.

See the attached logfile, taken in OLPC 11.3.0-os3.

Attachments (1)

org.laptop.AcousticMeasure-1.log (1.6 KB) - added by greenfeld 8 years ago.

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by greenfeld

comment:1 Changed 8 years ago by greenfeld

  • Cc godiard added
  • Keywords 11.3.0 added

comment:2 Changed 8 years ago by RafaelOrtiz

Please test w/ 26 of Distance.

comment:3 follow-up: Changed 8 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from new to closed

This is fixed now.

comment:4 in reply to: ↑ 3 ; follow-ups: Changed 8 years ago by godiard

Replying to RafaelOrtiz:

This is fixed now.

Have you tried in a XO 1.75?

comment:5 in reply to: ↑ 4 Changed 8 years ago by RafaelOrtiz

Replying to godiard:

Replying to RafaelOrtiz:

This is fixed now.

Have you tried in a XO 1.75?

I'll try and report.

comment:6 in reply to: ↑ 4 Changed 8 years ago by garycmartin

Replying to godiard:

Replying to RafaelOrtiz:

This is fixed now.

Have you tried in a XO 1.75?

I can get Distance-28 working between two XO-1s, but not between an XO-1 and XO-1.75 (no audio is generated). The log on the XO-1.75 (running build os5) is pretty long even for a simple test case, however I think the more notable message is:

ALSA lib pcm_mmap.c:396:(and_pcm_mmap) mmap failed: No such device or address
aplay: set_params:1116: Unable to install hw params:

So looks like an XO-1.75 specific audio issue.

comment:7 Changed 8 years ago by RafaelOrtiz

Tested also between and XO-1.5 and an XO-1.75 and it's not working.

comment:8 Changed 8 years ago by greenfeld

1.75 audio is still a work in progress. If 11.3.0 os6 does not solve issues with Distance, please wait a bit.

Pretty much every Sugar application except Speak was breaking at last check as soon as they tried to playback a sound.

Once gstreamer and the audio mixer work properly, then I believe pretty much everything should start working.

comment:9 Changed 8 years ago by RafaelOrtiz

Thanks for the update Samuel.

Note: See TracTickets for help on using tickets.