Opened 8 years ago

Closed 6 years ago

#3060 closed defect (notabug)

TA project wont copy to Documents

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

New 'Documents' feature in Journal, OS41

TA project will not copy from journal to Documents whereas most or all other projects will.

*.ta file will copy from Documents to journal and then back again

no error messages that i can see

Change History (5)

comment:1 Changed 8 years ago by walter

Could you please elaborate? Not sure what you are referring to.

I did the following test:

  1. Ran TA
  2. Copied journal entry (the 'TA project') to Documents using drag operation
  3. Found an appropriately named .ta file in Documents.
  4. Examined the contents of this file and observed they were correct
  5. Copied the file back into the Journal using operation, resulting in a new entry
  6. Opened the new journal entry successfully in TA

comment:2 Changed 8 years ago by tonyforster

1 ran TA
2 dragged to Documents

its not copied

but i just created another instance of ta and it will copy while the old instance will not

so i tried to copy it to usb
got error 'entries without file cannot be copied'

so maybe:
1) the ta entry is corrupted
2) copy to Documents needs the same error message as copy to usb
3) this bug should be filed under sugar

comment:3 Changed 8 years ago by walter

  • Component changed from Turtleart to sugar

RE 2) copy to Documents needs the same error message as copy to usb

Looking at the code, this seems to already be the case. Both the JournalButton and the DocumentsButton are subclasses of BaseButton, which is where the drag error messages are defined.

Any chance you could attach the file you suspect is corrupted?

thanks.

comment:4 Changed 8 years ago by tonyforster

Any chance you could attach the file you suspect is corrupted?

Sorry, I opened the journal entry in ta and when I closed it I got the dialog as for a new instance, now it copies.

I have just worked out what I did and how to create a blank instance : OS41, open TA, power down with 2 presses of the power button

Its also easy to replicate: try copying a Ruler instance, an error message to USB but silent to Documents

comment:5 Changed 6 years ago by walter

  • Resolution set to notabug
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.