Opened 8 years ago

Closed 8 years ago

#3046 closed defect (invalid)

Hmouse I18n errors

Reported by: RafaelOrtiz Owned by: rodripf
Priority: High Milestone: Unspecified
Component: hMouse Version: Unspecified
Severity: Unspecified Keywords:
Cc: cjl, alsroot Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

gettext is failling for an error en new.pot

new.pot:3: internationalized messages should not contain the `\r'

Change History (3)

comment:1 Changed 8 years ago by cjl

also fails to commit

Failed to commit file: [GIT] commit of ('/var/lib/pootle/checkouts/honey/hmouse', 'po/en_GB.po') failed: fatal: 'commit' is not possible because you have unmerged files. Please, fix them up in the work tree, and then use 'git add/rm <file>' as appropriate to mark resolution and make a commit, or use 'git commit -a'.

comment:2 Changed 8 years ago by cjl

  • Cc alsroot added
  • Priority changed from Normal to High

For some reason, gettext is picking up an odd character from the activity.info file

http://git.sugarlabs.org/hmouse/hmouse/blobs/master/activity/activity.info

#: activity/activity.info:2
msgid "hMouse\r"
msgstr ""

This is getting flagged as an error by the POT regeneration script.

/var/lib/pootle/checkouts/honey/hmouse/po/new.pot:3: internationalized messages should not contain the `\r' escape sequence

The activity.info file should be examined for the source of this odd \r character.

comment:3 Changed 8 years ago by alsroot

  • Resolution set to invalid
  • Status changed from new to closed

The problem is that activity.info was saved in DOS format (with \r\n for end-of-line symbol).
rodripf: would be useful to use UNIX format (\n).

In any case pootle (and sugar) should not fail in that case.
http://git.sugarlabs.org/pootle-helpers/cjl-tweaking-ini/commit/85103a3bd11b5e8715e9968a52df4a821f674a93

Closing this ticket, since it is not activity issue.

Note: See TracTickets for help on using tickets.