Opened 8 years ago

Closed 8 years ago

#3030 closed defect (wontfix)

set_rgb.py colour not shared

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Trivial Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

This is quite minor
If the colour is set by set_rgb.py and the session is shared, the receiving laptop does not use that colour

Change History (5)

comment:1 follow-up: Changed 8 years ago by walter

This is a more general problem in that none of the Python examples that manipulate graphics do any sharing. It is a bit complicated in this case, since there is not a current mechanism for sharing an RGB value; just for sharing a color index number. Can be done, but a use case would be a nice incentive.

comment:2 in reply to: ↑ 1 Changed 8 years ago by tonyforster

Replying to walter:

This is a more general problem in that none of the Python examples that manipulate graphics do any sharing.

What else is not shared?

I marked this issue as trivial, if its too hard then leave it as is.

comment:3 Changed 8 years ago by walter

The dotted-line example is also not shared as it directly accesses the graphics primitives -- probably a mistake on my part.

comment:4 Changed 8 years ago by tonyforster

I don't think using a graphics primitive (which sharing does not support) in a Python example is a mistake. Once programming in Python you have lower expectations of consistency than you would for turtle block programming.

comment:5 Changed 8 years ago by walter

  • Resolution set to wontfix
  • Status changed from new to closed

As per discussion, will not fix.

Note: See TracTickets for help on using tickets.