Opened 10 years ago

Closed 7 years ago

#3013 closed defect (obsolete)

toolbar error

Reported by: tonyforster Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: icarito, erikos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

os868au Sugar 0.84.31 XO1.5

Stop on toolbar does not work

line 183
Activitytoolbar has no attribute title

Change History (6)

comment:1 Changed 10 years ago by icarito

  • Cc icarito added

Hi,
I'm having trouble to reproduce. It would help if you could post the entire log?

Line 183 of sugarcommander.py doesn't show anything suspicious about the title for me.

This is also being tracked at http://dev.laptop.org.au/issues/823

comment:2 Changed 10 years ago by tonyforster

The first error was when I tried to stop, then alt tabbed to log.

Somewhere while alt tabbing past it, starting browse and so on, it generated lots more errors

/usr/lib/python2.6/site-packages/sugar/util.py:25: DeprecationWarning: the sha module is deprecated; use the hashlib module instead

import sha

(sugar-activity:2633): WARNING : expected enumeration type PangoWrapMode, but got GtkWrapMode instead
1312436801.533963 WARNING root: No gtk.AccelGroup in the top level window.
1312436801.544499 WARNING root: No gtk.AccelGroup in the top level window.
(sugar-activity:2633): DEBUG: Got client ID "1091922a5e76cf3f8b131243680244197800000024310000"
(sugar-activity:2633): DEBUG: Setting initial properties
(sugar-activity:2633): DEBUG: Received SaveYourself(SmSaveLocal, !Shutdown, SmInteractStyleNone, !Fast) in state idle
(sugar-activity:2633): DEBUG: Sending SaveYourselfDone(True) for initial SaveYourself
(sugar-activity:2633): DEBUG: Received SaveComplete message in state save-yourself-done
Traceback (most recent call last):

File "/usr/lib/python2.6/site-packages/sugar/activity/activity.py", line 183, in stop_clicked_cb

self._update_title(self.title.get_text())

AttributeError: 'ActivityToolbar' object has no attribute 'title'
1312436844.949026 ERROR dbus.connection: Exception in handler for D-Bus signal:
Traceback (most recent call last):

File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message

self._handler(*args, kwargs)

File "/home/olpc/Activities/SugarCommander.activity/sugarcommander.py", line 377, in datastore_updated_cb

object_id = self.selected_journal_entry.object_id

AttributeError: 'NoneType' object has no attribute 'object_id'
1312436848.605994 ERROR dbus.connection: Exception in handler for D-Bus signal:
Traceback (most recent call last):

File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message

self._handler(*args, kwargs)

File "/home/olpc/Activities/SugarCommander.activity/sugarcommander.py", line 377, in datastore_updated_cb

object_id = self.selected_journal_entry.object_id

AttributeError: 'NoneType' object has no attribute 'object_id'
1312437012.567512 ERROR dbus.connection: Exception in handler for D-Bus signal:
Traceback (most recent call last):

File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message

self._handler(*args, kwargs)

File "/home/olpc/Activities/SugarCommander.activity/sugarcommander.py", line 377, in datastore_updated_cb

object_id = self.selected_journal_entry.object_id

AttributeError: 'NoneType' object has no attribute 'object_id'

comment:3 Changed 10 years ago by quozl

  • Cc erikos added
  • Component changed from SugarCommander to sugar-toolkit
  • Owner changed from jdsimmons to erikos

Caused by a patch applied for #1948.

comment:4 Changed 10 years ago by quozl

Tested in 0.84.31 on OLPC OS 10.1.3 using the Log-20 activity, applying the NOT Adding A Journal Entry change, the Log activity then begins to fail in the same way; Stop button doesn't work, Ctrl/Q doesn't work, and the same traceback regarding line 183 of activity.py is reported in activity logs. Thus SugarCommander is excluded as cause.

comment:5 Changed 8 years ago by dnarvaez

  • Component changed from sugar-toolkit to Sugar

comment:6 Changed 7 years ago by godiard

  • Resolution set to obsolete
  • Status changed from new to closed

I think this is a very old bug already fixed. Please reopen if needed.

Note: See TracTickets for help on using tickets.