Opened 10 years ago

Closed 10 years ago

#3012 closed enhancement (obsolete)

Use system installed Box2d if available

Reported by: garycmartin Owned by: garycmartin
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Physics Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Test for a system installed Box2d package before adding to the python path for the version shipped inside the bundle. This should allow running the same Physics bundle on a wider range of hardware/distros (XO 1.75 ARM) while still supporting existing deployments.

Change History (1)

comment:1 Changed 10 years ago by garycmartin

  • Resolution set to obsolete
  • Status changed from new to closed

Physics will already use a system installed Box2d (in preference to the local bundle) due to the search path order. No change needed, works fine on ARM hardware now that Box2d is in the official builds.

Note: See TracTickets for help on using tickets.