Opened 8 years ago

Closed 3 years ago

#3006 closed defect (fixed)

Ad-hoc network icon mixup

Reported by: dsd Owned by:
Priority: Normal Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

If you create an regular (non-auto-Sugar) ad-hoc network (e.g. on a non-sugar system) on channels 1, 6 or 11, it appears in Sugar's neighborhood view as the standard circle with signal level indicated by the height of the shape inside the circle (just like infrastructure networks). When you click to connect to the network, the device icon in the frame appears differently - instead of the signal level being shown, it appears with the Mayan symbol (like the auto-Sugar adhoc networks).

Not sure which representation is correct/desired, but the fact that the same network is displayed differently in the frame vs neighborhood view is a bug.

Secondly, if you create a non-auto-Sugar adhoc network on another system, on a channel that is *not* 1, 6, or 11, it will again appear on the neighborhood view like an infrastructure network, but clicking on it to create a connection results in a blank network icon in the frame. This is because it is trying to find an icon named (e.g.) network-adhoc-8.

Change History (3)

comment:1 Changed 5 years ago by walter

  • Priority changed from Unspecified by Maintainer to Normal

comment:3 Changed 3 years ago by quozl

  • Resolution set to fixed
  • Status changed from new to closed

Was applied as b86b623 and fixes both issues; the inconsistency of icons between neighbourhood view and frame; and the wrong icon name used for channel 8 adhoc networks. Tested with adhoc networks.

Note: See TracTickets for help on using tickets.