Opened 10 years ago

Closed 10 years ago

#2975 closed defect (fixed)

Moon: Grid button must be a RadioToolButton

Reported by: godiard Owned by: garycmartin
Priority: Low Milestone: Unspecified
Component: Moon Version: Unspecified
Severity: Minor Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

The grid button switch the grid on/off. I think wolud br better if the button looks pressed when the grid is show.

Change History (1)

comment:1 Changed 10 years ago by garycmartin

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in git http://git.sugarlabs.org/moon/mainline/commit/4197e7adaa97511c8aef7875226004c6386047bc though at the cost of loosing button deb ounce code (toggle buttons don't seem to accept blocks). Code is a little simpler, but if a user double clicks a button by mistake, they will see no visible change (because they toggle the feature on and off again before the redraw can complete).

Note: See TracTickets for help on using tickets.