Opened 10 years ago

Closed 10 years ago

#2966 closed defect (fixed)

default stamp size is far too small

Reported by: dsd Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Paint Version: Unspecified
Severity: Unspecified Keywords:
Cc: manuq Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Me, Simon and testers on the testing list have all tried the Stamp functionality, and, while cool, we all think the default size is far too small. Could this be increased?

Attachments (1)

0001-Initial-stamp-size-set-based-on-the-display-s-DPI.patch (1.4 KB) - added by manuq 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by godiard

The user can change the stamp size in the palette of the brush, or using keys + / -

May be is not very intuitive....

comment:2 Changed 10 years ago by dsd

Thats fine - its great that it can be increased and decreased. This request is that it starts, by default, on a larger size, rather than the miniscule setting it has now.

comment:3 Changed 10 years ago by godiard

  • Cc manuq added

Ok,I understand now. Yes we can change the default size.

We need check the resolution too, because in a 96 dpi desktop is not so small, but in the XO is too much.

comment:4 Changed 10 years ago by manuq

Yes, currently the stamp size is 20 pixels the biggest side, very narrow on a XO.

I tested another sizes, and I think 60 pixels works better in a XO.

An alternative is to use a proportion of the screen resolution, but I'm not sure if adding this dependency in the functionality can be a good thing.

comment:5 Changed 10 years ago by manuq

Attached a fix: sets the initial size of the stamp based on the screen's dpi.

comment:6 Changed 10 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Thanks, Manuel. Tested and pushed.

Note: See TracTickets for help on using tickets.