Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#2960 closed defect (duplicate)

Avoid having tons of gnome-keyring-daemon while restarting sugar-emulator

Reported by: alsroot Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

After adding a workarond http://bugs.sugarlabs.org/ticket/2339#comment:2 for https://bugzilla.gnome.org/show_bug.cgi?id=628302,
it is possible to have tons of gnome-keyring-daemon launched, one after each sugar-emulator launch.

|TestCase|

  • gnome-keyring-daemon is not being used in the system (not started)
  • start sugar-emulator
  • exit it
  • gnome-keyring-daemon is still in ps

Attachments (1)

0001-Avoid-having-tons-of-gnome-keyring-daemon-while-rest.patch (955 bytes) - added by alsroot 10 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by alsroot

  • Keywords r? added

comment:2 Changed 10 years ago by alsroot

  • Resolution set to duplicate
  • Status changed from new to closed

Seems to be that the only component that triggers gnome-keyring is MC, thus it is a dup of #2278

comment:3 Changed 9 years ago by humitos

I test the Test Case with this PATCH and it still happens. I mean, after closing sugar-emulator "gnome-keyring" is still there.

comment:4 Changed 9 years ago by alsroot

  • Keywords r? removed

Yeah, for me too.

Thats why Sweets Distribution uses its won telepathy-mission-control that is being built w/o gnome-keyring support. No gnome-keyring in MC, no problems.

Note: See TracTickets for help on using tickets.