Opened 7 years ago

Closed 6 years ago

#296 closed enhancement (fixed)

Active point of Paint pointers should be at tip of pencil, brush, drip on fill bucket, etc.

Reported by: FGrose Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Paint Version: 0.84.x
Severity: Unspecified Keywords: Paint GPA
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

Some of the Paint pointers release their 'ink' at an unexpected points on the image.

This is most critical for the fill action on small targets, but also confusing or frustrating when it is a hidden point, such as the shape arrow.

Please adjust the 'release' point to the following proposed locations:

  • very tip of the pencil & brush
  • at bottom of drip on the fill bucket
  • exact point of arrow on arrow shape
  • lower-left corner of eraser (this works with 1 to ~6 pixel diameters, but on larger diameter erase fields, the erase field has its upper-left corner at the eraser pointer's lower-left corner.
    • center the erase field of sized shapes on the corner of the eraser
  • exact lower-left corner for polygon tool (please also rotate the triangle on the pointer to point at that corner)
  • exact lower-left corner of the rectangular marquee (It initially appears as a square with the active point somewhat displaced. On subsequent clicks, it becomes a crosshair pointer that works appropriately.)
  • at a new highlight (bright pixel or two) on the exact edge of the circle for the ellipse shape
  • more in the table linked below.

All proposals can be found in a table for general review at

http://wiki.laptop.org/go/Talk:Paint#Pointer_Tips

Thanks for a great tool!

Change History (7)

comment:1 Changed 7 years ago by FGrose

Eben has entered an alternative proposal at http://dev.laptop.org/ticket/4315. It may be easier or preferred, but is less fun, because, for example, the fill bucket would pour paint upwards.

Perhaps the standard arrow could be rotated to match the proposed points and appear more as a ghost behind the tool-specific pointer images. It would be harder to get each image to look good with the alternative solution.

comment:2 Changed 7 years ago by FGrose

Eben also enter a ticket to use some Sugar theme cursors, http://dev.laptop.org/ticket/4316.

Brian has filed a similar ticket, http://dev.laptop.org/ticket/8864.

comment:3 Changed 7 years ago by FGrose

  • Bug Status changed from Unconfimed to New
  • Component changed from SoaS to design
  • Distribution/OS changed from SoaS to Unspecified
  • Version changed from 0.83.x to 0.84.x

comment:4 Changed 7 years ago by gregorio

  • Keywords GPA added

Hi Guys,

I can confirm this is an issue based on GPA in class experience with Paint. See: http://www.mail-archive.com/iaep@lists.sugarlabs.org/msg05534.html and search for Paint for some comments on issues.

I added GPA to the keyword.

Thanks,

Greg S

comment:5 Changed 7 years ago by FGrose

  • Component changed from design to Paint

comment:6 Changed 6 years ago by godiard

  • Owner changed from marcopg to godiard
  • Status changed from new to assigned

commited to git

comment:7 Changed 6 years ago by godiard

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.