Opened 10 years ago

Closed 10 years ago

#2946 closed defect (fixed)

sugar-jhbuild crashes when installing Read [15/27]

Reported by: walter Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: sugar-jhbuild Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS:
Bug Status: Unconfirmed

Description

File "/home/walter/Desktop/sugar-jhbuild/jhbuild/jhbuild/frontends/buildscript.py", line 146, in build

error, altphases = module.run_phase(self, phase)

File "/home/walter/Desktop/sugar-jhbuild/jhbuild/jhbuild/modtypes/init.py", line 230, in run_phase

method(buildscript)

File "/home/walter/Desktop/sugar-jhbuild/sjhbuild/bundlemodule.py", line 88, in do_install

buildscript.packagedb.add(self.name, self.get_revision() or )

TypeError: add() takes exactly 4 arguments (3 given)

This is on a Fedora 14 system. Update and Depcheck reported no errors.

Change History (1)

comment:1 Changed 10 years ago by sascha_silbe

  • Distribution/OS Unspecified deleted
  • Resolution set to fixed
  • Status changed from new to closed

Caused by incompatible upstream changes, fixed by 2e01f34.

Thanks for the report!

Note: See TracTickets for help on using tickets.