Opened 10 years ago

Closed 8 years ago

#2937 closed defect (notsugar)

Pygame Performance with pulseaudio

Reported by: pmoleri Owned by: bernie
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Dextrose Version: 0.88.x
Severity: Major Keywords:
Cc: alsroot Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

This problem was detected in olpc xo-1.0 using Dextrose image from Uruguay (dxo-uy-1.0).

After executing in python:

import pygame
pygame.init()

the proccess pulseaudio shows 10% cpu usage.

Changing the SDL audio driver is a workaround:

import os
os.environ['SDL_AUDIODRIVER'] = 'alsa'

import pygame
pygame.init()

Change History (5)

comment:1 Changed 10 years ago by alsroot

  • Cc alsroot added

To what exact activity you added pygame workaround?

In any case would be useful to change Component field to that exact activity (and create similar bugs for the all pygame activities). Because these are different people who maintains all these activities (unfortunately Sugar doesn't handle activity deps in some cases people bundle pygame to theirs activities).

comment:2 Changed 10 years ago by pmoleri

I used the workaround in an activity I'm working on.

It would be nice to fix the problem for the next Dextrose release, I don't know if it's a SDL problem or a pulseaudio problem, but I guess is one of these.

In the older image (802c) that problem didn't occur.

comment:3 Changed 10 years ago by alsroot

  • Component changed from untriaged to Dextrose
  • Owner set to bernie

comment:4 Changed 10 years ago by RafaelOrtiz

iirc this was tested on an activity that pablo is working on, seems like a general issue.

comment:5 Changed 8 years ago by dnarvaez

  • Resolution set to notsugar
  • Status changed from new to closed

Dextrose is not tracked here anymore.

Note: See TracTickets for help on using tickets.