Opened 8 years ago

Closed 8 years ago

#2898 closed defect (fixed)

Calculate 18n improvement

Reported by: cjl Owned by: rwh
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Calculate Version: Unspecified
Severity: Unspecified Keywords:
Cc: garycmartin Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by RafaelOrtiz)

toolbars.py:292

Degrees / radians

change to

Degrees / Radians

Change History (6)

comment:1 Changed 8 years ago by garycmartin

If we change the source string won't we break all the existing pootle translations for this string, or does pootle/gettext ignore case when finding a match?

comment:2 Changed 8 years ago by walter

gettext is case-sensitive

comment:3 Changed 8 years ago by cjl

We just need to check with Rafael and Gonzalo about the genpot process. POT files get updated all the time, we just want to make sure it happens properly by following the changes all the way into the git POT file and then into Pootle.

The fuzzy matching algorithm of "Updating from Templates" would successfully match on mismatched case. The result would be the translated strings being populated, but flagged as fuzzy. Chances are many localizations would be fine either because they already capitalize the second word (like Spanish "Grados / Radianes") which currently causes the string to get flagged with the simplecaps pofilter or the localizers will simply change the case of the second word and "unfuzzy" the string and recommit the PO file. No big deal.

comment:4 Changed 8 years ago by RafaelOrtiz

  • Description modified (diff)

cjl is right, this change will make it to pootle on order to translators to change the case. Np.

comment:5 Changed 8 years ago by cjl

  • Cc garycmartin added

Can we please fix this.

comment:6 Changed 8 years ago by garycmartin

  • Resolution set to fixed
  • Status changed from new to closed

Fix pushed to git mainline (updated both source and matching poodle string).

Note: See TracTickets for help on using tickets.