Opened 10 years ago

Closed 8 years ago

#2892 closed defect (notsugar)

Several Activities fail to launch in crowded jabber.sugarlabs.org Neighborhood

Reported by: FGrose Owned by: mchua pbrobinson sdz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: 11.3.0
Cc: dsd, erikos, pbrobinson, alsroot Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by FGrose)

Observed on http://fedora.roving-it.com/SoaSv5-20110612-x86_64.iso
installed with onboard livecd-iso-to-disk.

Surf, Terminal, Log, Physics, Clock, Record, & Turtle Art failed to launch with similar error logs.

See logs attached.

Re: http://lists.sugarlabs.org/archive/soas/2011-June/002224.html

Attachments (10)

org.laptop.Surf-1.log (1.4 KB) - added by FGrose 10 years ago.
org.laptop.Terminal-1.log (1.4 KB) - added by FGrose 10 years ago.
org.laptop.Log-1.log (1.4 KB) - added by FGrose 10 years ago.
org.laptop.physics-1.log (1.6 KB) - added by FGrose 10 years ago.
tv.alterna.Clock-1.log (1.4 KB) - added by FGrose 10 years ago.
org.laptop.RecordActivity-1.log (1.5 KB) - added by FGrose 10 years ago.
org.laptop.TurtleArtActivity-1.log (1.5 KB) - added by FGrose 10 years ago.
shell.log (937.4 KB) - added by FGrose 10 years ago.
presenceservice.log (3.0 KB) - added by FGrose 10 years ago.
Crowded Neighborhood.png (1.0 MB) - added by FGrose 10 years ago.

Download all attachments as: .zip

Change History (23)

Changed 10 years ago by FGrose

Changed 10 years ago by FGrose

Changed 10 years ago by FGrose

Changed 10 years ago by FGrose

Changed 10 years ago by FGrose

Changed 10 years ago by FGrose

Changed 10 years ago by FGrose

Changed 10 years ago by FGrose

Changed 10 years ago by FGrose

comment:1 Changed 10 years ago by FGrose

  • Description modified (diff)

comment:2 Changed 10 years ago by walter

Looking at the Turtle Art log, I see an error that crops up occasionally (one that I never understood), but has never prevented Turtle Art from launching. It is curious that suddenly it is fatal.

comment:3 Changed 10 years ago by FGrose

This problem also occurs with Sugar in standard Fedora-15 Desktop (fully updated) when the Sugar environment is selected at login.

I noticed from the yum.log that dbus-libs was updated:

Jun 01 22:32:44 Installed: 1:dbus-libs-1.4.6-4.fc15.i686

Changed 10 years ago by FGrose

comment:4 Changed 10 years ago by FGrose

  • Component changed from Sugar on a Stick (SoaS) to untriaged
  • Distribution/OS changed from Fedora to Unspecified
  • Summary changed from [SoaS 5] Several Activities fail to launch to Several Activities fail to launch in crowded jabber.sugarlabs.org Neighborhood

Booting SoaS 5 with a disconnected Ethernet cable eliminates this problem.

It seems the crowded jabber.sugarlabs.org Neighborhood (see the attached Neighborhood screenshot) interferes with the Activity startup process.

I noticed the same startup failures (same trackbacks) on an XO-1 with OLPC os23 when set to the jabber.sugarlabs.org Neighborhood.

comment:5 Changed 10 years ago by erikos

  • Keywords 11.2.0 added

comment:7 Changed 10 years ago by sascha_silbe

  • Component changed from untriaged to sugar

comment:8 follow-up: Changed 10 years ago by dsd

  • Cc dsd erikos added

While this is an important bug that should be investigated and fixed, in a sense I think the real problem is jabber.sugarlabs.org

This jabber server is presenting so many buddies (thousands - I think) that gabble produces more dbus traffic than you can imagine, announcing buddy status via signals etc. I'm fairly confident that this bug would not appear on saner servers.

I had a quick look at this issue anyway, and I didn't find much on my first glance. Sugar has timeouts on dbus calls going into the activity (usually SetActive), and the activity has timeouts on dbus calls going into sugar. dbus-monitor output didn't really agree with that, showing that SetActive had been called and returned, and I didn't see the failed call from the activity even appear on ths bus. Definitely worth looking further into, but the findings might be that dbus is simply too clogged up thanks to gabble noise.

comment:9 Changed 10 years ago by pbrobinson

  • Cc pbrobinson added

comment:10 in reply to: ↑ 8 Changed 10 years ago by alsroot

Replying to dsd:

While this is an important bug that should be investigated and fixed, in a sense I think the real problem is jabber.sugarlabs.org

This jabber server is presenting so many buddies (thousands - I think) that gabble produces more dbus traffic than you can imagine, announcing buddy status via signals etc. I'm fairly confident that this bug would not appear on saner servers.

As was already mentioned in #2963, it is not only jabber.sl.o issue but also a misbehaviour on the client side. It was fixed in http://lists.sugarlabs.org/archive/sugar-devel/2011-July/032295.html.

btw, "saner" means here not-for-development-purpose servers, because bunch of offline users in the roster (though it is partially fixed on jabber.sl.o) is because of peopel while developing sugar many times recreates jids. Eventually it is insane sugar client side behaviour.

comment:11 Changed 10 years ago by alsroot

  • Cc alsroot added

In my investigation I got feeling that this issue is gabble related (and sound like a design bug in the gabble) #2973.

This issue can't be reproducible on low traffic servers but was reproducible on previous jabber.sl.o w/ 2K of offline users in the roster (for now it behaves smoothly).

People who need to reproduce this issue need to have jabber server w/ shared roster w/ 2K+ offline buddies (and jabber.sl.o is not a good candidate for such stress testing since it started working in more-or-less production mode and would be better to avoid having lags for people who don't take part in such stress tests) and w/ gabble version from #2973.

comment:12 Changed 10 years ago by erikos

  • Keywords 11.3.0 added; 11.2.0 removed

comment:13 Changed 8 years ago by dnarvaez

  • Resolution set to notsugar
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.