Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2840 closed defect (fixed)

Write: problem opening RTF files

Reported by: godiard Owned by: godiard
Priority: High Milestone: Unspecified
Component: Write Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

The teachers in Ury say they have problem opening RTF files. (They see the controls characteres like if was opened like a TXT file)

We must try creating the files with Word and Open Office and saving again in Write.

I have tested but can't reproduce yet. They use Write 72 in dx

Change History (5)

comment:1 Changed 8 years ago by RafaelOrtiz

I tested this on dextrose and i wasn't able to reproduce, dunno what's happening here.

comment:2 in reply to: ↑ description Changed 8 years ago by sascha_silbe

Replying to godiard:

The teachers in Ury say they have problem opening RTF files. (They see the controls characteres like if was opened like a TXT file)

Sounds like a MIME type issue. Most likely not a bug in Write, but in something involved with transferring the file to the Sugar system, e.g. an HTTP server. Can you get details on their process (how do they transfer the files to Sugar)?

comment:3 Changed 8 years ago by godiard

  • Keywords olpc-test added; 11.2.0 removed
  • Resolution set to fixed
  • Status changed from new to closed

We can't reproduce it also in 11.2

I have tried with files created in MS Word and OpenOffice too.

If needed can be opened again.

comment:4 Changed 8 years ago by greenfeld

  • Keywords olpc-test removed

I created an RTF file using LibreOffice, and manually inspected said file to verify it was indeed looked like an RTF file. I then copied it to a USB stick and started it from the Sugar journal view in OLPC 11.3.0-3.

The RTF file opened properly in Write-75.

Perhaps we need to get a sample broken file?

comment:5 Changed 8 years ago by godiard

I think we can close it, and reopen if needed.

Note: See TracTickets for help on using tickets.