Opened 8 years ago

Closed 7 years ago

#2834 closed defect (obsolete)

navigator.userAgent does not identify OLPC/Sugar

Reported by: bert Owned by: lucian
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Browse Version: Git as of bugdate
Severity: Major Keywords: dx2, dx3
Cc: Distribution/OS:
Bug Status: New

Description

Browse currently does not identify itself as OLPC or Sugar in the useragent string. It looks like a generic Linux browser. This is a regression, it worked fine in older versions.

This breaks e.g. the Squeakland showcase (http://http://squeakland.org/showcase/everyone/) which needs to identify Sugar to download Etoys projects to the Journal. It uses javascript:navigator.userAgent and looks for the substring "olpc".

Change History (2)

comment:1 Changed 8 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to New
  • Distribution/OS Unspecified deleted
  • Version changed from Unspecified to Git as of bugdate

Confirmed on Debian Squeeze. Some digging revealed that the Sugar version was previously set by hulahop (prefs.js.in, configure.ac).

There are several issues:

  1. Yielding incorrect version numbers since hulahop versions are not coupled to Sugar releases (anymore).
  2. Distributions replacing the Sugar version with their own custom string (e.g. Debian/0.7.1-3+1)
  3. The setting from prefs.js not getting used at all: The user agent string received by the server is "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20080724 Firefox/3.0".

We should

  1. Figure out how to set the user agent within Browse and how to determine the "Sugar Platform" version the current system is supporting, and
  2. Release a new version of hulahop that removes the hardcoded Sugar version.

comment:2 Changed 7 years ago by manuq

  • Resolution set to obsolete
  • Status changed from new to closed

This is already in current Browse that features WebKit, was commited as 4c856a7eccf873bcd04fb1ee8701a241175e6e03 . Closing.

Note: See TracTickets for help on using tickets.