Opened 9 years ago

Closed 7 years ago

#2823 closed defect (fixed)

Funding request: renew sugarlabs.{org,net}

Reported by: bernie Owned by: cjl
Priority: Urgent Milestone: Unspecified
Component: fundingrequest Version: Unspecified
Severity: Critical Keywords:
Cc: walter Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

What is being purchased?

Renew 2 domains at name.com

Why does this purchase benefit the operations of Sugar Labs?

Without a domain name, we'd be hard to find on the Internet

Who will be responsible for the item?

The Sugar Labs Infrastructure Team

How much will it cost?

$9.99 per domain

What other options were evaluated for purchase?

I used gandi.net, godaddy.com, joker.com in the past. name.com is by far superior and has very low prices.

What were the criteria or features you needed?

  • Practical management interface, free of ads and marketing junk
  • IPv6 support for nameservers
  • DNSSEC support

What deadlines are associated with this request?

sugarlabs.net expires on Jun 04.
sugarlabs.org would expire on May 05. I've already renewed it out of my pocket because we don't have a fast process to approve expenses.

Other notes?

Filling in this ticket costed me more time than paying $9.99 out of my pocket. Can we please have pre-approval to reimburse expenses up to a certain cap?

Change History (8)

comment:1 follow-up: Changed 9 years ago by walter

Since my wings seem to have been clipped, I have been approving such requests on my own dime, betting that SLOBs in its wisdom will approve. So go for it and if for some reason SLOBs decides no, I'll find the money elsewhere.

comment:2 in reply to: ↑ 1 Changed 9 years ago by bernie

Replying to walter:

Since my wings seem to have been clipped, I have been approving such requests on my own dime, betting that SLOBs in its wisdom will approve. So go for it and if for some reason SLOBs decides no, I'll find the money elsewhere.

This mechanism requiring a board vote for each individual funding request is simply ridiculous :-)

If we can't agree on a trusted individual who can approve small expenses, we'd better stop accepting donations.

comment:3 Changed 8 years ago by bernie

  • Resolution set to wontfix
  • Status changed from new to closed

Closing as WONTFIX.

I seriously recommend the SLOBs to reconsider the process for requesting funding.

comment:4 follow-up: Changed 8 years ago by cjl

  • Cc walter added
  • Resolution wontfix deleted
  • Status changed from closed to reopened

Bernie,

I thought we had you pre-approved up to something like $200.

Two days ago, you closed this a "wontfix" with a comment, but I thought it had been resolved in a sensible way a while ago.

If you are impeded in maintaining our systems (and internet presence) efficiently then we still have a bug that needs to be addressed, I want to address it and not WONTFIX it.

cjl

comment:5 Changed 8 years ago by cjl

  • Owner changed from mchua to cjl
  • Status changed from reopened to assigned

comment:6 in reply to: ↑ 4 Changed 8 years ago by bernie

Replying to cjl:

Bernie,

I thought we had you pre-approved up to something like $200.

Indeed, the funding request process doesn't affect me any more, but I feel it's still a burden for everybody else. Perhaps we could extend this $200 cap to all team coordinators?

If you are impeded in maintaining our systems (and internet presence) efficiently then we still have a bug that needs to be addressed, I want to address it and not WONTFIX it.

I've been renewing the domains out of pocket because I felt it wasn't worth wasting the time of SL and SFC volunteers for such a small amount.

I filed this bug mainly to show that our funding request process was dysfunctional. If we do agree it should be streamlined, I'd have some ideas.

comment:7 Changed 7 years ago by dnarvaez

  • Milestone not applicable deleted

Milestone not applicable deleted

comment:8 Changed 7 years ago by walter

  • Milestone set to Unspecified
  • Resolution set to fixed
  • Status changed from assigned to closed

We resolved the funding mechanism issue long ago. Presumably we also renewed sl.org and .net

Note: See TracTickets for help on using tickets.