Opened 8 years ago

Closed 4 years ago

#2822 closed defect (obsolete)

Software Update selects new activities by default

Reported by: sridhar Owned by: m_anish
Priority: Normal Milestone: Unspecified
Component: Sugar Version: 0.84.x
Severity: Unspecified Keywords:
Cc: sridhar Distribution/OS: OLPC
Bug Status: Assigned

Description

If you run the Software Update tool in Sugar, it will automatically select every available bundle, regardless of whether it is currently installed or not. What it should do is only select bundles that can be upgraded. New bundles should be unticked. The user can manually select them if they want.

This is how update systems like yum and apt-get work — they separate the upgrade functionality from the install functionality.

Change History (6)

comment:1 Changed 8 years ago by sridhar

Also tracked at http://dev.laptop.org.au/issues/383

This will allow us to provide repositories of optional activities that are easily installable. In the current scenario, anything we add to a repository (e.g. http://wiki.laptop.org/go/Activities/OLPCAU/10.1.3) is forced on the user unless they explicitly untick the item.

comment:2 Changed 7 years ago by sascha_silbe

  • Component changed from untriaged to Dextrose
  • Owner set to bernie

comment:3 Changed 7 years ago by m_anish

  • Bug Status changed from Unconfirmed to Assigned
  • Owner changed from bernie to m_anish
  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Minor
  • Status changed from new to assigned

This has been added from dx3ng51>= with a patch.

No closing, since this should be pushed upstream (together with the microformat based updater)

comment:4 Changed 5 years ago by dnarvaez

  • Resolution set to notsugar
  • Status changed from assigned to closed

Dextrose is not tracked here anymore.

comment:5 Changed 4 years ago by JerryV

  • Component changed from Dextrose to Sugar
  • Resolution notsugar deleted
  • Severity changed from Minor to Unspecified
  • Status changed from closed to reopened

comment:6 Changed 4 years ago by godiard

  • Resolution set to obsolete
  • Status changed from reopened to closed

This problem can be solved using the feature "Optional activity updates"

http://wiki.sugarlabs.org/go/Features/Optional_activity_updates

Note: See TracTickets for help on using tickets.