Opened 10 years ago

Closed 8 years ago

#2804 closed defect (duplicate)

Corner case: Control panel modal dialog gets restricted to activity view or obscured

Reported by: m_anish Owned by:
Priority: Normal Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Minor Keywords: dx2, dx3 11.3.0
Cc: bernie, sascha_silbe, walter, erikos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

I just encountered a interesting corner case which results in the control panel modal dialog being restricted to the activity view

Testcase

  • Open a heavy activity like record which takes some time, or use a slow computer ;-)
  • While the activity is opening, quickly switch to home view (F3) and open the control panel.

Observations: dx3, sugar-jhbuild/0.92

(The usual control panel modal dialog opens)

(The activity launches in the background behind the modal dialog)

  • While this is happening, the user can switch between different views (neighborhood, friend, home) and the control panel modal dialog is no longer visible there.

Observations: dx2, sweets/0.88

(The usual control panel modal dialog opens)

(The activity launches and obscures the control panel modal dialog)

  • Closing the activity reveals the Control Panel modal dialog again

OR

  • The user can try switching to different views where the dialog is no longer visible.

Note:

  • I do not see any exception/traceback in shell.log which could have been caused by this.
  • Someone needs to test this on a 0.84 if possible. I don't have one close-by right now

Attachments (1)

Screenshot of _Record Activity_.png (46.3 KB) - added by m_anish 10 years ago.
Screenshot of CP modal panel in front of record activity. Dextrose-3, sugar-0.92.x

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by m_anish

Screenshot of CP modal panel in front of record activity. Dextrose-3, sugar-0.92.x

comment:1 Changed 10 years ago by erikos

  • Keywords 11.2.0 added

comment:2 Changed 10 years ago by erikos

  • Keywords 11.3.0 added; 11.2.0 removed

comment:3 Changed 10 years ago by sascha_silbe

  • Cc sascha_silbe erikos added; silbe removed

I intended to mark this as a dupe of another ticket, but apparently the described behaviour hasn't been documented yet. Related issues are #1138, #2576 and #453.

Modal dialogs are hard to get right - even more so if they're global (application-modal isn't much easier, but the effects are limited to a single application / activity). We need to try harder to avoid them.

comment:4 Changed 8 years ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:5 Changed 8 years ago by walter

Also related to #4601

comment:6 Changed 8 years ago by dnarvaez

  • Resolution set to duplicate
  • Status changed from new to closed

Seems like a dup of #4601.

Note: See TracTickets for help on using tickets.