Opened 9 years ago

Closed 8 years ago

#2795 closed defect (fixed)

Cannot export

Reported by: tonyforster Owned by: humitos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Write Version: Unspecified
Severity: Unspecified Keywords: patch
Cc: humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

May relate to #2598
Cannot export txt, rtf, pdf
OS373pyg Write 73 XO1.5

Traceback (most recent call last):

File "/home/olpc/Activities/Write.activity/widgets.py", line 228, in activate_cb

fileObject.metadatakeep? = act_metakeep?

File "/usr/lib/python2.6/site-packages/sugar/datastore/datastore.py", line 100, in getitem

return self._properties[key]

KeyError: 'keep'
/home/olpc/Activities/Write.activity/AbiWordActivity.py:245: GtkWarning: gdk_window_set_cursor: assertion `GDK_IS_WINDOW (window)' failed

pixbuf = self.abiword_canvas.render_page_to_image(1)

1303475886.368297 WARNING root: DSObject was deleted without cleaning up first. Call DSObject.destroy() before disposing it.
Traceback (most recent call last):

File "/home/olpc/Activities/Write.activity/widgets.py", line 228, in activate_cb

fileObject.metadatakeep? = act_metakeep?

File "/usr/lib/python2.6/site-packages/sugar/datastore/datastore.py", line 100, in getitem

return self._properties[key]

KeyError: 'keep'
1303475905.162308 WARNING root: DSObject was deleted without cleaning up first. Call DSObject.destroy() before disposing it.
Traceback (most recent call last):

File "/home/olpc/Activities/Write.activity/widgets.py", line 228, in activate_cb

fileObject.metadatakeep? = act_metakeep?

File "/usr/lib/python2.6/site-packages/sugar/datastore/datastore.py", line 100, in getitem

return self._properties[key]

KeyError: 'keep'
1303475915.796455 WARNING root: DSObject was deleted without cleaning up first. Call DSObject.destroy() before disposing it.
Traceback (most recent call last):

File "/home/olpc/Activities/Write.activity/widgets.py", line 228, in activate_cb

fileObject.metadatakeep? = act_metakeep?

File "/usr/lib/python2.6/site-packages/sugar/datastore/datastore.py", line 100, in getitem

return self._properties[key]

KeyError: 'keep'

Attachments (3)

grecord-10.py (24.7 KB) - added by tonyforster 9 years ago.
fails to export this file
abiword_export_test.py (1.2 KB) - added by humitos 8 years ago.
Exportation test with all the supported types by Write
0001-Optional-data-when-it-exports-a-file-SL-2795.patch (2.0 KB) - added by humitos 8 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by RafaelOrtiz

Export works for me on sugar 0.88 / dextrose 2. can
you update your os and try again ?.

Changed 9 years ago by tonyforster

fails to export this file

comment:2 Changed 9 years ago by tonyforster

here's the doc it failed on (attached)
still 373pyg

comment:3 Changed 8 years ago by godiard

  • Owner changed from uwog to godiard
  • Status changed from new to assigned

Tony, can you confirm if this is happening with a updated Write activity?

comment:4 Changed 8 years ago by HoboPrimate

I tried exporting the .py file with Write 78 and fails with the same error above.

comment:5 Changed 8 years ago by tonyforster

Thanks HoboPrimate, looks like I missed this request for testing. Yes it fails on Write78, OS8, XO-1.75

comment:6 Changed 8 years ago by humitos

  • Cc humitos added
  1. I downloaded the grecord-10.py file from this ticket
  2. I opened it with Write activity
  3. I see all the XML tags (as you see it on Trac)
  4. I click on "Export as RTF"

I got this error:

Traceback (most recent call last):
  File "/home/olpc/Activities/Write.activity/widgets.py", line 231, in __clicked_cb
    fileObject.metadata['share-scope'] = act_meta['share-scope']
  File "/usr/lib/python2.7/site-packages/sugar/datastore/datastore.py", line 100, in __getitem__
    return self._properties[key]
KeyError: 'share-scope'

I tested this on XO 1.5, build os9, Write 78

Changed 8 years ago by humitos

Exportation test with all the supported types by Write

comment:7 Changed 8 years ago by humitos

  • Keywords patch added

comment:8 Changed 8 years ago by humitos

  • Owner changed from godiard to humitos
  • Status changed from assigned to accepted

comment:9 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from accepted to closed

Thanks, pushed. Will be in Write 80.

Note: See TracTickets for help on using tickets.