Opened 10 years ago

Closed 9 years ago

#2779 closed defect (fixed)

secondary toolbar icons and labels are missing

Reported by: walter Owned by: mchua pbrobinson sdz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar on a Stick (SoaS) Version: 0.92.x
Severity: Blocker Keywords:
Cc: alsroot Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Sugar 0.92 on F15 has some issues with the toolbars. Icons and labels do not appear on secondary toolbars. Other toolbar components such as spinners appear. The buttons themselves seem to work, as do tooltips. But their graphics are not rendered.

I haven't determined whether this is a problem with the theme path not picking up activity-specific icons or some other issue. (Doesn't explain the label problem, however).

Test:

  1. Open the Calculate activity
  2. Open a secondary toolbar
  3. Observe that none of the icons appear

Test:

  1. Download Abacus from ASLO
  2. Open the Custom toolbar
  3. Observe that the spinners are not labelled.

Change History (5)

comment:1 Changed 10 years ago by walter

  • Severity changed from Unspecified to Blocker

/usr/lib/python2.7/site-packages/sugar/graphics/toolbarbox.py:108: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed

self.props.palette.add(self.page_widget)

/usr/lib/python2.7/site-packages/sugar/graphics/window.py:195: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed

self.vbox.pack_start(toolbar_box, False)

One of these warning may be relevant? (I don't get them on F14.)

comment:2 Changed 10 years ago by walter

  • Cc alsroot added

We should CC Aleksey on this ticket. My current suspicion is that the for some reason the do_expose_event in the toolbarbox is not being propagated to the buttons in the box. (But that wouldn't explain why widgets other than buttons are rendered properly.)

comment:3 Changed 10 years ago by pbrobinson

Walter: I believe this is now fixed. Please confirm.

comment:4 Changed 10 years ago by walter

Yes although I never understood the root cause.

comment:5 Changed 9 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.