Opened 10 years ago

Closed 9 years ago

#2742 closed defect (fixed)

Pippy's Xolympics example may be too CPU intensive on an XO-1, or feel unfair

Reported by: greenfeld Owned by: lfaraone
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Pippy Version: 0.92.x
Severity: Minor Keywords: 11.3.0
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

It's hard for me to describe how to reproduce this bug, but Pippy's Xolympics example may be too CPU intensive on an XO-1 or otherwise seem unfair, especially once you have a few balls bouncing around.

When you have two players actively going (one using WASD and the other using the arrow keys) along with a few balls, there are times when it feels like one triangle player is able to jump very high while the other cannot obtain any significant height at all. But placing both triangles on the ground, waiting for them to stabilize, and pressing W and Up simultaneously usually shows them jumping to the same height.

Seen in 11.2.0 os14/Pippy-40

Change History (2)

comment:1 Changed 10 years ago by godiard

  • Keywords 11.3.0 added; 11.2.0 removed

I think Xolympics is only a example of use of the physics engine, not example of fair play.

Doing a good game, is more difficult and IMHO is out of the scope of the example.

For me, this is not a bug.

comment:2 Changed 9 years ago by quozl

  • Resolution set to fixed
  • Status changed from new to closed

xolympics example has been removed.

Note: See TracTickets for help on using tickets.