Opened 8 years ago

Closed 4 years ago

#2739 closed enhancement (obsolete)

Pippy should indicate when a modified or completely new Python program is being run

Reported by: greenfeld Owned by: lfaraone
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Pippy Version: 0.92.x
Severity: Minor Keywords:
Cc: Distribution/OS: OLPC
Bug Status: New

Description

Pippy should indicate when a modified or completely new Python program is being run. This likely is because the user modified an existing program or pressed the "Erase" button to indicate that they wanted to enter a new program.

This is especially confusing when entering a new program, because the Example selector still highlights the last selected program, making me feel like I just potentially overwrote it.

Seen in OLPC 11.2.0 os14/Pippy-40.

Change History (2)

comment:1 Changed 8 years ago by RafaelOrtiz

  • Bug Status changed from Unconfirmed to New

comment:2 Changed 4 years ago by tch

  • Resolution set to obsolete
  • Status changed from new to closed

In Pippy version 58, this issue is no longer present. The examples selector was re-designed and does not need to highlight the current example.

Note: See TracTickets for help on using tickets.