Opened 9 years ago

Closed 8 years ago

#2734 closed defect (fixed)

Log activity should not update search results every keystroke

Reported by: greenfeld Owned by: humitos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Log Version: 0.92.x
Severity: Minor Keywords: 12.1.0, easy-hack
Cc: humitos Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Searching a log file using the Search toolbar up top updates the result every keystroke. The updates also highlight every example found in the text of the current value of the search bar (even if a single letter), and may shift the text side-to-side to show the results if word wrap is disabled.

This can make it very painful to use on an XO-1 with large log files such as shell.log with Sugar and debug logging enabled.

To borrow what seems to be a common (but not necessarily the most user obvious?) Sugar search box approach, we likely should return new search results in Log only when the <Enter> key is pressed, and somehow indicate when no results are returned as well.

Seen in OLPC 11.2.0 os14.

Attachments (1)

0001-Don-t-update-search-results-every-keystroke-SL-2734.patch (3.6 KB) - added by humitos 8 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by godiard

  • Keywords easy-hack added

comment:2 Changed 8 years ago by humitos

  • Cc humitos added

comment:4 Changed 8 years ago by godiard

  • Keywords 12.1.0 added

comment:5 Changed 8 years ago by godiard

  • Owner changed from wadeb to godiard
  • Status changed from new to assigned

comment:6 Changed 8 years ago by godiard

  • Owner changed from godiard to humitos

Thanks, pushed as be9a9ba437ddf78457240473f256a7379e9f07fa

Will be available in next Log 29

comment:7 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.