Opened 10 years ago

Closed 10 years ago

#2724 closed defect (fixed)

Pootle Templates getting mangled

Reported by: cjl Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: localization Version: Unspecified
Severity: Critical Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

In Honey project, something keeps on reverting the POT uploads I've done on a handful of activities to bring them current.

arithmetic, calendario, cartoonbuilder, clock, gogo, kandid, measure-activity, record, story-builder, sugar-commander, TamTamJam

There must be a cron job pointing at the wrong repo or something that keeps on doing this. It then propagates these erroneous changes when user's "update from Templates".

Change History (4)

comment:1 Changed 10 years ago by RafaelOrtiz

arithmetic.po 27 > 1
calendario.po 53 > 55
cartoonbuilder.po 39 > 34
clock.po 38 > 8
gogo.po 437 > 1
paths.po 44 > 84
record.po 117 > 1
speak.po 138 > 139
story-builder.po 11 > 4
sugar-commander.po 23 > 34
TamTamJam.activity.po 391 > 302
TamTamMini.activity.po 346 > 261

activities that have this problem. some due to merge/pull conflicts some other because they are not regenerating pot's o.k

comment:2 Changed 10 years ago by cjl

There are actually two issues. The first one as reported was that the Templates projext was getting updated incorrectly (not the most recent), probably by some weekly cron job. The second one is even after manually fixing templates project, "Update from Templates" is not pulling properly from Templates project and giving incorrect string numbers.

comment:3 Changed 10 years ago by cjl

  • Severity changed from Major to Critical
  • Summary changed from Poolte Templates getting mangled to Pootle Templates getting mangled

Bumping up priority.

Spanish, Nepali, French, Portuguese (Brazil) Honey projects all have wrong string counts and can't easily be fixed until this is corrected.

comment:4 Changed 10 years ago by cjl

  • Resolution set to fixed
  • Status changed from new to closed

Closing this ticket as obsolete now. Not all are fixed, but I'll fix them or file new tickets for them.

Note: See TracTickets for help on using tickets.