Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#271 closed defect (obsolete)

Journal and List view disappear after going into VT

Reported by: mchua Owned by: marcopg
Priority: High Milestone:
Component: Sugar Version: 0.82.x
Severity: Critical Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Needinfo

Description

Switching to VT to view favoriteslayout.py and favoritesview.py files, then back to Sugar, has caused the Journal and List view to disappear from the UI. The problem disappears on a reboot and no Journal data is lost.

Found by Alastair on an XO running build 767 (Sugar 0.82.1). This is currently unreproducible, but has concerning enough effects that we're posting logs and keeping track of our reproduction attempts here. The sequence of events, as best as we can piece them together, was:

# Use Measure with a sensor (potentiometer) plugged in; everything in Sugar seems to be working correctly.
# Decide to change your Favorites view layout; drop into a virtual terminal (ctrl-alt-Neighborhood).
# cd into /usr/share/sugar/shell/view/home
# view and edit favoriteslayout.py and favoritesview.py (using ls, nano, and less)
# ctrl-alt-Home back into Sugar
# notice that the Journal is gone from Favorites view
# switch to List view; notice that List view is empty
# switch back to Favorites view
# start Log Activity, which starts and functions properly.
# switch to VT and copy log files to USB stick.
# switch back to Favorites view and reboot.
# notice the Journal and List view have returned
# notice that there doesn't seem to be a loss of data from the Journal (all old sessions are still there)
# notice that the Journal contains an item for the Log Activity session you started while Journal and List were unavailable through the UI

Logs from the "invisible Journal and List view" session are attached; note that datastore.log is empty. We are trying to reproduce this but have been unsuccessful so far.

Attachments (1)

invisible-journal-and-list-view.tar.gz (4.6 KB) - added by mchua 12 years ago.

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by mchua

comment:1 Changed 12 years ago by marcopg

The shell service seems to be blocked or crashed. If you run into it again please check with top if sugar-shell-service is running/taking cpu. Thanks!

comment:2 Changed 12 years ago by tomeu

  • Version changed from Unspecified to 0.82.x

comment:3 Changed 12 years ago by marcopg

  • Distribution/OS changed from Unspecified to OLPC
  • Milestone changed from Unspecified by Release Team to 0.84
  • Priority changed from Unspecified by Maintainer to High
  • Severity changed from Unspecified to Critical

comment:4 Changed 12 years ago by erikos

  • Bug Status changed from Unconfimed to Needinfo

We need to find someone to reproduce this.

comment:5 Changed 12 years ago by alsroot

  • Resolution set to obsolete
  • Status changed from new to closed

Could someone reproduce this issue?
Since its 0.82 and shell code was changed significantly..
Feel free to reopen ticket if this issue still exists..

comment:6 Changed 8 years ago by godiard

  • Milestone 0.84 deleted

Milestone 0.84 deleted

Note: See TracTickets for help on using tickets.