Opened 10 years ago

Closed 10 years ago

#2699 closed defect (duplicate)

Long numbers mess up Calculate's history log area

Reported by: greenfeld Owned by: rwh
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Calculate Version: 0.92.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Type a long number such as "7777777777777777777777777777" into Calculate which exceeds the length of the entry area, and then press "Enter". It will exceed the length of the area displaying the result of this simple calculation.

Then type in a series of simple calculations like "1+1", "2", "3*4", "pi", etc. The right-aligned results of these in the results column will be pushed off screen because the long number originally entered apparently has increased the size of these fields beyond what an XO can show.

Seen in Calculate-36 / OLPC 11.2.0 os13.

Change History (5)

comment:1 Changed 10 years ago by greenfeld

  • Distribution/OS changed from Unspecified to OLPC

comment:2 Changed 10 years ago by greenfeld

  • Summary changed from Long numbers mess up Calculate's to Long numbers mess up Calculate's history log area

comment:3 Changed 10 years ago by garycmartin

Thanks for the clear report, looks like this might be a dup of #2126

comment:4 Changed 10 years ago by sascha_silbe

  • Component changed from untriaged to Calculate
  • Owner set to rwh

comment:5 Changed 10 years ago by garycmartin

  • Resolution set to duplicate
  • Status changed from new to closed

Pretty sure this is a dupe of #2126 please re-open if you think it is different.

Note: See TracTickets for help on using tickets.