Opened 10 years ago

Closed 10 years ago

#2692 closed defect (duplicate)

Browse download doesn't handle journal full from background download

Reported by: hal.murray Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: untriaged Version: 0.92.x
Severity: Major Keywords:
Cc: Distribution/OS:
Bug Status: Unconfirmed

Description

It pops up a Journal-Full window with a button to click so you can delete something. But clicking that button gets the same window again.

It would really help if the Journal entries told you how big things were so you could decide which one(s) to delete.

I'm seeing this on XO-1 running Sugar 0.92.0 (os12).

I deleted some stuff. df says 95% used, 49340K available. I still get that message when exiting an activity. The save seems to have worked. Does it need more than 5% free space, or is the "full" flag stuck on?

Change History (1)

comment:1 in reply to: ↑ description Changed 10 years ago by sascha_silbe

  • Distribution/OS Unspecified deleted
  • Resolution set to duplicate
  • Severity changed from Unspecified to Major
  • Status changed from new to closed
  • Version changed from Unspecified to 0.92.x

Replying to hal.murray:

It pops up a Journal-Full window with a button to click so you can delete something. But clicking that button gets the same window again.

Sounds like a dupe of #630. Feel free to reopen this bug if you disagree.

It would really help if the Journal entries told you how big things were so you could decide which one(s) to delete.

Since Sugar 0.90 you can sort the Journal list view by size. Choose "Sort by size" on the palette of the sort icon (the one that has the up/down arrows). The last column shows values of the property that the Journal is currently sorted by (time since last modification, time since creation and size, respectively).

I deleted some stuff. df says 95% used, 49340K available. I still get that message when exiting an activity. The save seems to have worked. Does it need more than 5% free space, or is the "full" flag stuck on?

You need to have at least 50MB free:

_SPACE_TRESHOLD = 52428800
Note: See TracTickets for help on using tickets.