Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2683 closed defect (fixed)

Help not working

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

was #2676
downloaded from git turtleartactivity.py which includes
http://git.sugarlabs.org/turtleart/mainline/commit/d9679562ee14fe0ef3ac4139728d88eb0b796f05

OS861au 0.84 is OK

OS439dg 0.88 does not show help

Change History (3)

comment:1 Changed 10 years ago by walter

  • Status changed from new to accepted

Hmm. This seems to be a GTK problem as opposed to a Sugar problem. I'll need to probe what version of GTK is installed and take appropriate action.

comment:2 follow-up: Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from accepted to closed

The problem is gtk. I now check for gtk version and if it is 2.16 or less, I do not set the label width, reverting back to the occasional truncated help strings (which presumably is better than no help strings.) With latter gtk versions, the label works as designed.

http://git.sugarlabs.org/turtleart/mainline/commit/e5b14faacc882a8f14d86bcda309263d9b6b3957

comment:3 in reply to: ↑ 2 Changed 10 years ago by sascha_silbe

Replying to walter:

The problem is gtk. I now check for gtk version and if it is 2.16 or less, I do not set the label width, reverting back to the occasional truncated help strings (which presumably is better than no help strings.) With latter gtk versions, the label works as designed.

It would be nice if you could document your workaround on the Compatibility Tips wiki page.

Note: See TracTickets for help on using tickets.