Opened 10 years ago

Closed 10 years ago

#2663 closed defect (fixed)

[dx2] Flakey issue with mouse pointer theme

Reported by: m_anish Owned by: m_anish
Priority: High Milestone: Unspecified
Component: Dextrose Version: Unspecified
Severity: Minor Keywords: dx2
Cc: bernie, silbe, tch, alsroot Distribution/OS: Dextrose
Bug Status: New

Description (last modified by m_anish)

We have observed that the mouse pointer reverts to its standard gtk cursor theme in some obscure cases.

I don't have a testcase that reproduces this issue. What does fix the issue, however, is enabling the accessiblity|mouse cursor and disabling it.

Not yet clear if this is an issue with Dextrose or sugar in general. Need to search if there is a related bug report in the olpc bugtracker.

This bug has also been observed on dextrose-1 builds in use in Caacupe.

Change History (4)

comment:1 Changed 10 years ago by m_anish

  • Description modified (diff)

comment:2 Changed 10 years ago by m_anish

  • Component changed from untriaged to Dextrose
  • Owner set to m_anish
  • Priority changed from Normal to High
  • Status changed from new to assigned

Increasing priority. This maybe a minor usability concern, but looks pretty bad.

comment:3 Changed 10 years ago by sascha_silbe

Have you found any way to reproduce the issue?
Where does it happen (Neighbourhood, some activity, Control Panel, etc.)? Is the effect restricted to that "area" or is the cursor "stuck" even after switching screens?

comment:4 Changed 10 years ago by tch

  • Resolution set to fixed
  • Status changed from assigned to closed

This problem was caused by a combination of a weak logic at bin/sugar script plus some changes added by dx accessibility patches.

The fixes are already included in dextrose 2 line, and it will be necessary to forward port to dx3.

Note: See TracTickets for help on using tickets.