Opened 8 years ago

Closed 5 years ago

#2659 closed defect (obsolete)

[dx2] Browse should have a cache cleaning policy

Reported by: m_anish Owned by: lucian
Priority: Urgent Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Critical Keywords: dx2
Cc: tch, dirakx, lucian, bernie, erikos, icarito Distribution/OS: Dextrose
Bug Status: New

Description

Browse cache can bloat up with time consuming valuable space on the laptop.

On one laptop me and tch checked, there were 400MB of unaccessible files (mostly multimedia) in the Browse instance folder.

Thus, Browse should have some kind of cache cleaning policy. For example, we could clean the cache after every one week or so.

Change History (7)

comment:1 Changed 8 years ago by RafaelOrtiz

Also we can look in ways of setting preferences (or combination of preferences) as per

http://kb.mozillazine.org/About:config_entries

comment:2 Changed 8 years ago by m_anish

  • Cc erikos added
  • Priority changed from Normal to Urgent
  • Severity changed from Major to Critical

This seems to be a bigger issue than we initially anticipated. Many kids in Caacupe have bloated up browser caches and the space on an XO-1 runs out real quick.

I'd also be interested in knowing whether this exists on other releases 0.84/OLPC, 0.88/OLPC 0.92.1/OLPC 0.92.1/DX3 as well.

Adding erikos in cc, since this is might be a big real world problem.

comment:3 Changed 8 years ago by RafaelOrtiz

Testing big downloads with icarito, seems to have brought this problem into surface,specially when a download is cancelled or interrupted for example due to a network disconnection. Browse should erase cache when either this situations occur.

comment:4 Changed 8 years ago by RafaelOrtiz

Well, it's not exactly cache that bloats out the filesystem, are partial downloads.
there is a commit on mainline to address this.

comment:5 Changed 8 years ago by RafaelOrtiz

Fix packaged in browse 121.

comment:6 Changed 8 years ago by icarito

  • Cc icarito added

Partial fix in http://git.sugarlabs.org/browse/mainline/commit/cc38d3bdc7f7f3ab4ed166166e0a8a71c2cbeaf0

However, this does not cover the case when Browse or Sugar crash. We need a procedure to clean instance/ when starting browse (needs to check it is the only instance to avoid corner case of more than one browse instance). Another option is to check the date of partial files...

Leaving open, adding me as cc.

comment:7 Changed 5 years ago by godiard

  • Resolution set to obsolete
  • Status changed from new to closed

Browse already have a mechanism to delete old files

https://github.com/sugarlabs/browse-activity/blob/master/webactivity.py#L245

If any file is missed, we need open a bug with information about how reproduce the problem

Note: See TracTickets for help on using tickets.