Opened 10 years ago

Closed 5 years ago

#2649 closed defect (fixed)

Help - i18n required

Reported by: cjl Owned by: garycmartin
Priority: High Milestone: Unspecified
Component: Help Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Help is a critical content/activity bundle, but it is only available in English. This is a real problem. This content would be very useful if localized.

Either Help
http://git.sugarlabs.org/help

or New_Help
http://git.sugarlabs.org/new_help

Should be set up for localization in Pootle by performing internationalization to generate a POT file. It is understood that this is not a standard activity with short strings, but it is very important that this activity (which OLPC ships on every build) undergo i18n and L10n.

Change History (2)

comment:1 Changed 10 years ago by RafaelOrtiz

This is an already seen use case where we should detect $LANG and in that case install the desirable bundle.

comment:2 Changed 5 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Help activity already support localization, and is documented how to do it: https://github.com/godiard/help-activity/blob/master/howto_translate.rst

Is not using pootle, due to the huge number of words involved, and the need of use many files.

Note: See TracTickets for help on using tickets.