Opened 10 years ago

Closed 10 years ago

#2643 closed defect (fixed)

Commit links in Pootle missing

Reported by: cjl Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: localization Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

In the en_US Honey project (and most languages but lang-es) "Update from VCS" and "Commit to VCS" are links missing for the following.

abacus.po (in some languages)
analyze.po
calendario.po
fototoon.po
gogo.po
karma_6_english_animalidentification.po
maze.po
read-sd-comics.po
sugar-commander.po

stopwatch.po (not yet in Honey template see #2642)

The PO files (for all but stopwatch) are there to be translated, but we need the commit links for the language admins to do their part after they've been completed.

Attachments (1)

Honey_commit_matrix.xls (34.0 KB) - added by cjl 10 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 10 years ago by RafaelOrtiz

This must be fixed for all this activities, just a note about stopwatch, that has no .pot templates, so maint or developer must do it, other way could be clone it and work from there.

comment:2 Changed 10 years ago by cjl

StopWatch.pot is located here:

http://dev.laptop.org/git/activities/stopwatch/tree/po/StopWatch.pot

Not sure why I was unable to upload to Templates ( #2642 )but hopefully that can be resolved.

comment:3 Changed 10 years ago by RafaelOrtiz

Oh ok. i think that I overlook it.

comment:4 Changed 10 years ago by RafaelOrtiz

This must be fixed now for all the activities minus abacus and stopwatch.

comment:5 Changed 10 years ago by RafaelOrtiz

Must be fixed now. please test.

comment:6 Changed 10 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 10 years ago by cjl

  • Resolution fixed deleted
  • Status changed from closed to reopened

Re-opening, I still don't see the commit links here:

http://translate.sugarlabs.org/en_US/honey/edit.html

comment:8 Changed 10 years ago by RafaelOrtiz

Right..I found the issue, for the missing links it seems that pootle is not seeing some templates as versionated.

comment:9 follow-up: Changed 10 years ago by RafaelOrtiz

tha lack of commit link must be due to the fact that some templates are not being updated.

I got this traceback

[Tue Mar 08 20:22:37 2011] [error] return f(request, path_obj, *args, kwargs)
[Tue Mar 08 20:22:37 2011] [error] File "/usr/lib/python2.6/dist-packages/pootle_app/views/language/admin_files.py", line 53, in view
[Tue Mar 08 20:22:37 2011] [error] project_tree.convert_templates(template_translation_project, translation_project)
[Tue Mar 08 20:22:37 2011] [error] File "/usr/lib/python2.6/dist-packages/pootle_app/project_tree.py", line 267, in convert_templates
[Tue Mar 08 20:22:37 2011] [error] convert_template(store.file.path, new_store_path)
[Tue Mar 08 20:22:37 2011] [error] File "/usr/lib/python2.6/dist-packages/pootle_app/project_tree.py", line 241, in convert_template
[Tue Mar 08 20:22:37 2011] [error] output_file.close()
[Tue Mar 08 20:22:37 2011] [error] UnboundLocalError: local variable 'output_file' referenced before assignment
[Tue Mar 08 20:22:37 2011] [error]
[Tue Mar 08 20:22:50 2011] [error] Exception KeyError: KeyError(140115470223168,) in <module 'threading' from '/usr/lib/python2.6/threading.py'> ignored

comment:10 in reply to: ↑ 9 Changed 10 years ago by RafaelOrtiz

Replying to RafaelOrtiz:

the lack of commit link must be due to the fact that some templates are not being updated.

This is for some languages.

I got this traceback

[Tue Mar 08 20:22:37 2011] [error] return f(request, path_obj, *args, kwargs)
[Tue Mar 08 20:22:37 2011] [error] File "/usr/lib/python2.6/dist-packages/pootle_app/views/language/admin_files.py", line 53, in view
[Tue Mar 08 20:22:37 2011] [error] project_tree.convert_templates(template_translation_project, translation_project)
[Tue Mar 08 20:22:37 2011] [error] File "/usr/lib/python2.6/dist-packages/pootle_app/project_tree.py", line 267, in convert_templates
[Tue Mar 08 20:22:37 2011] [error] convert_template(store.file.path, new_store_path)
[Tue Mar 08 20:22:37 2011] [error] File "/usr/lib/python2.6/dist-packages/pootle_app/project_tree.py", line 241, in convert_template
[Tue Mar 08 20:22:37 2011] [error] output_file.close()
[Tue Mar 08 20:22:37 2011] [error] UnboundLocalError: local variable 'output_file' referenced before assignment
[Tue Mar 08 20:22:37 2011] [error]
[Tue Mar 08 20:22:50 2011] [error] Exception KeyError: KeyError(140115470223168,) in <module 'threading' from '/usr/lib/python2.6/threading.py'> ignored

comment:11 Changed 10 years ago by RafaelOrtiz

This was a bug in pootle..I changed this file for a new one. while the upgrade happens, hopefully solves the issue.

Changed 10 years ago by cjl

comment:12 Changed 10 years ago by cjl

Attached matrix of lang versus po file for Honey.

Each x represents missing "Update /Commit to VCS" links.

There are a lot of "x" marks.

comment:13 Changed 10 years ago by RafaelOrtiz

From the backend side of thigs this seems to be o.k. so I already consulted with sayamindu to see what is happening there.

comment:14 Changed 10 years ago by RafaelOrtiz

Let's keep this bug as a collector for activites failing to commit.

cjl thanks for the matrix!.

comment:15 Changed 10 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from reopened to closed

This is due to the fact that add_langs.py script were not runned after a new lang was created from pootle.

from the readme

admin/pootlepopulator.py

This script checks out a project from Git into /var/lib/pootle/checkouts/..., and
then creates the appropiate symlinks in /var/lib/pootle/translations/...

Usage: pootlepopulator.py category GIT_URL checkout_directory git_branch
Eg: pootlepopulator.py glucose git://dev.laptop.org/git/sugar sugar master

admin/add_langs.py

The pootlepopulator.py script has a minor problem. Once a project is visible, and
a new language is added to it from the web based interface, the new PO file gets
created in /var/lib/pootle/translations/... where it should ideally be a symlink.
To counter this, admin/add_langs.py has to be run after a new language has been
added.
This script runs without any arguments and crawls through the subdirectories of
/var/lib/pootle/translations/... When it finds a non-symlink PO file, it moves it
to the right location, git adds it and makes the correct symlink.

I've run the script to add langs..setting as fixed because we know the cause of the bug.

running the script takes ages and there could be langs with this links still missing, will be added as demanded.

Note: See TracTickets for help on using tickets.