Opened 10 years ago

Closed 10 years ago

#2626 closed enhancement (fixed)

Add en language to Google Translation bar

Reported by: alsroot Owned by: FGrose
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: wiki.sugarlabs.org Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Needinfo

Description

It might be useful, eg, if original text was posted in non-en language.

Change History (7)

comment:1 Changed 10 years ago by FGrose

  • Bug Status changed from Unconfirmed to Needinfo

Done. Please test.

The link takes a language pair plus help language.
The English link is en, en, en.

comment:2 Changed 10 years ago by FGrose

Not done.

Looks like we'll need some way to extract the source language.

In Google Chrome, I have Preferences > Under the Hood, Translate check box that helps.

comment:3 Changed 10 years ago by FGrose

Reader can pick the source language once they reach the Google translate (error) page.

comment:4 Changed 10 years ago by alsroot

There is an "auto" feature, ie, instead of langpair=en|en it might be sl=auto&dl=en.

comment:5 Changed 10 years ago by FGrose

auto seems to work!

English link now has auto, en, auto

Thanks for the idea and research.

comment:6 Changed 10 years ago by FGrose

Adjusted to show help in English (consistent with others having help in the requested display language).

Adjusted sort to latin phonetic, sorta.

comment:7 Changed 10 years ago by alsroot

  • Resolution set to fixed
  • Status changed from new to closed

Seems to work, tested on http://wiki.sugarlabs.org/go/Vuelta_a_Uruguay
So, I'm closing the ticket.

Note: See TracTickets for help on using tickets.