Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2600 closed defect (fixed)

GCompris | Reading Activities -> Click on a Letter | No Sound for Spanish locale

Reported by: m_anish Owned by: alsroot
Priority: Immediate Milestone: Unspecified
Component: GCompris Version: Unspecified
Severity: Blocker Keywords:
Cc: dirakx, alsroot Distribution/OS: Dextrose
Bug Status: New

Description

In the GCompris-15 complete activity suite, there is no sound for:

'Reading Activities' -> 'Click on a Letter' Activity for Spanish locales

Its probably due to some missing/incorrect files?

Seen on Dextrose-2 builds.

Change History (9)

comment:1 Changed 10 years ago by m_anish

  • Component changed from untriaged to GCompris
  • Owner set to alsroot

comment:2 Changed 10 years ago by RafaelOrtiz

This is working with new version from ASLO gcompris v.16.

http://activities-testing.sugarlabs.org/downloads/file/27191/gcompris-16.xo

comment:3 Changed 10 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 10 years ago by RafaelOrtiz

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reponed..because it's not working on xo-1.

comment:5 Changed 10 years ago by alsroot

  • Keywords dx2 removed
  • Summary changed from [dx2] GCompris | Reading Activities -> Click on a Letter | No Sound for Spanish locale to GCompris | Reading Activities -> Click on a Letter | No Sound for Spanish locale

Looks like it is gstreamer related issue.
src/gcompris/gstreamer.c:fx_play(), in some cases, raises gst fails (error messages on bus). Further disposing the pipe doesn't work because pipe state is not NULL (setting it NULL doesn't work immediately, disposing on state changed bus message leads to segfaults). Though, it can be reproducible only on XO-1 and fc11 (the same fc11 on XO-1.5 works fine).

I'm removing dx2 keyword since v17 has a workaround, it disables music. In that case, voices/sounds work fine.

comment:6 Changed 10 years ago by RafaelOrtiz

==> Test in xo-1.0

comment:7 Changed 10 years ago by RafaelOrtiz

Very difficult to test with the gcompris full bundle (because of memory constrains), at least on an XO-1.0

comment:8 Changed 10 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from reopened to closed

v17 working, reported by m_anish

comment:9 Changed 10 years ago by alsroot

Actually, it is downstream issue, not GCompris. On dextrose, there is a lack of gst-pulse plugin and GC uses alsa directly (and XO-1 doesn't have hw mixer), thus GC can't sound two pipelines at the same time.

Note: See TracTickets for help on using tickets.