Opened 10 years ago

Closed 10 years ago

#2595 closed enhancement (fixed)

add Tab for #sugar-es to IRC activity-making default IRC have 2 tabs

Reported by: satellit Owned by: mchua
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Irc Version: Unspecified
Severity: Unspecified Keywords: IRC, #sugar-es
Cc: Distribution/OS: Other (name your distribution in the description)
Bug Status: Unconfirmed

Description

add Tab for #sugar-es to IRC activity. Thus there would be 2 Tabs:
#sugar
#sugar-es

This would facilitate inter_language communication on IRC.
Especially for spanish speaking students first asking for help.

Change History (6)

comment:1 Changed 10 years ago by walter

Not clear that the solution shouldn't be to get $LANG and derive from that what tab to open as opposed to having as specific solution for Spanish.

comment:2 Changed 10 years ago by sascha_silbe

I'd like to suggest a slight variation: connect to #sugar and #sugar-<google language code>, with the language code being derived from the locale (either directly if Google uses ISO 639 language codes, or indirectly using a lookup table).

comment:3 in reply to: ↑ description Changed 10 years ago by alsroot

Replying to satellit:

add Tab for #sugar-es to IRC activity. Thus there would be 2 Tabs:
#sugar
#sugar-es

This would facilitate inter_language communication on IRC.
Especially for spanish speaking students first asking for help.

I might be implemented as in webirc patch (login to see the bar with sugar channels and languages).
So people need to choose the channel (would be useful, at least to see the list of all sugar related channels) and the language, then click "Join". After that IRC needs to do some lingva magic to open translation channel.

comment:4 follow-up: Changed 10 years ago by RafaelOrtiz

I've been tackling this with pygtk, for other versions we must tackle it with webirc, because it's easier to extend as alsroot did with webirc.

comment:5 in reply to: ↑ 4 Changed 10 years ago by RafaelOrtiz

Replying to RafaelOrtiz:

I've been tackling this with pygtk, for other versions we must tackle it with webirc, because it's easier to extend as alsroot did.

comment:6 Changed 10 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from new to closed

This is implemented in V9 closing. opening new one for having specific-locales for irc.

Note: See TracTickets for help on using tickets.