Opened 10 years ago

Closed 7 years ago

#2592 closed defect (obsolete)

[dx2] Favorites view | Scattered layout | Overlapping icons incorrectly placed after restarting

Reported by: m_anish Owned by:
Priority: Normal Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Minor Keywords: dx2
Cc: garymartin Distribution/OS: Dextrose
Bug Status: Unconfirmed

Description (last modified by m_anish)

Testcase:

  1. Open favorites view
  1. Select scattered layout, icons are randomly placed
  1. Try to drag one activity icon over another

(Sugar intelligently places them one next to another and not overlapping)

4.A Restart sugar
OR
4.B. Try dragging the icons one over another again

5.A. Icons reduce in their size
AND/OR
5.B. Icons overlap and cover each other up

Seen on Dextrose and sugar-jhbuild

Attachments (1)

2592.gif (159.9 KB) - added by m_anish 10 years ago.
bug reproduced in jhbuild (fast h/w required to play gif image)

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by m_anish

  • Description modified (diff)

comment:2 Changed 10 years ago by walter

I cannot reproduce this on the 0.90.1 Sugar on Fedora 14 or in sugar-jhbuild.

comment:3 Changed 10 years ago by walter

Note that this patch was never applied. It doesn't address this specific ticket, but it is a much cleaner implementation of the spiral code than is currently in mainline.

http://bugs.sugarlabs.org/attachment/ticket/2235/0001-a-more-succint-approach-to-the-spiral-morph.patch

Note that this patch applies to the 0.88 version of favoriteslayout.py

comment:4 follow-up: Changed 10 years ago by walter

  • Cc garymartin added

I still cannot reproduce the overlap problem, but the problem with shrinking is failing to account for the increase in the maximum size of the icons in the Ring View.

The question is, what should be the size of the icons in the Random View? Should it track the size in the Ring View?

comment:5 Changed 10 years ago by m_anish

  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Minor

Changed 10 years ago by m_anish

bug reproduced in jhbuild (fast h/w required to play gif image)

comment:6 in reply to: ↑ 4 Changed 10 years ago by m_anish

Replying to walter:

I still cannot reproduce the overlap problem, but the problem with shrinking is failing to account for the increase in the maximum size of the icons in the Ring View.

The question is, what should be the size of the icons in the Random View? Should it track the size in the Ring View?

<walterbender> silbe, m_anish: re #2592, it was decided to keep the Random icons always at 'Standard Size'
<m_anish> walterbender, but the current behavior is that the icon size gets reduced?
<walterbender> m_anish: only if you start with large icons
<walterbender> m_anish: if the icons are never large, they won't shrink
<walterbender> m_anish: I introduced the regression when I make the icons large by default.

comment:7 Changed 7 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from new to closed

Very old, unreproducable bug.

Note: See TracTickets for help on using tickets.